summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit00370f2de9e5825d29ca212d51ed35388567b48d (patch)
treefbd98eac91baf6271f55be3aa165475eae5ce777 /sys-apps
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadgentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.gz
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.bz2
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bash/bash-2.04-r4.ebuild85
-rw-r--r--sys-apps/bzip2/files/digest-bzip2-1.0.1-r41
-rw-r--r--sys-apps/debianutils/debianutils-1.13.3-r4.ebuild52
-rw-r--r--sys-apps/debianutils/files/digest-debianutils-1.13.3-r41
-rw-r--r--sys-apps/file/file-3.33-r3.ebuild40
-rw-r--r--sys-apps/file/files/digest-file-3.33-r31
-rw-r--r--sys-apps/fileutils/files/digest-fileutils-4.1-r21
-rw-r--r--sys-apps/fileutils/fileutils-4.1-r2.ebuild56
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.1-r61
-rw-r--r--sys-apps/findutils/findutils-4.1-r6.ebuild70
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.0.6-r41
-rw-r--r--sys-apps/gawk/gawk-3.0.6-r4.ebuild52
-rw-r--r--sys-apps/grep/files/digest-grep-2.4.2-r41
-rw-r--r--sys-apps/grep/grep-2.4.2-r4.ebuild50
-rw-r--r--sys-apps/gzip/files/digest-gzip-1.2.4a-r41
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r4.ebuild73
-rw-r--r--sys-apps/portage/portage-1.5.2.ebuild4
-rw-r--r--sys-apps/sed/files/digest-sed-3.02.80-r31
-rw-r--r--sys-apps/sed/sed-3.02.80-r3.ebuild50
-rw-r--r--sys-apps/sh-utils/files/digest-sh-utils-2.0j-r41
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild66
-rw-r--r--sys-apps/tar/files/digest-tar-1.13.19-r11
-rw-r--r--sys-apps/tar/tar-1.13.19-r1.ebuild61
-rw-r--r--sys-apps/textutils/files/digest-textutils-2.0.10-r31
-rw-r--r--sys-apps/textutils/textutils-2.0.10-r3.ebuild49
-rw-r--r--sys-apps/util-linux/util-linux-2.11g.ebuild4
26 files changed, 720 insertions, 4 deletions
diff --git a/sys-apps/bash/bash-2.04-r4.ebuild b/sys-apps/bash/bash-2.04-r4.ebuild
new file mode 100644
index 000000000000..7e2e53740b16
--- /dev/null
+++ b/sys-apps/bash/bash-2.04-r4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
+ ftp://ftp.gnu.org/gnu/bash/${A}"
+
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2
+ readline? ( >=sys-libs/readline-4.1-r2 )
+ tex? ( app-text/tetex )
+ "
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ "`use readline`" ]
+ then
+ myconf="--with-installed-readline"
+ fi
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ try ./configure --prefix=/ --mandir=/usr/share/man \
+ --infodir=/usr/share/info --host=${CHOST} \
+ --disable-profiling --with-curses \
+ --enable-static-link ${myconf}
+
+ try pmake
+
+ if [ "`use tex`" ] && [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ cd support
+ cp texi2html texi2html.orig
+ sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
+ texi2html.orig > texi2html
+ cd ../doc
+ try make
+ fi
+
+}
+
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ doman doc/*.1
+
+ if [ -z "`use readline`" ]
+ then
+ doman doc/*.3
+ fi
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+
+ if [ "`use tex`" ]
+ then
+ docinto html
+ dodoc doc/*.html
+ docinto ps
+ dodoc doc/*.ps
+ fi
+ else
+ rm -rf ${D}/usr
+ fi
+
+}
+
diff --git a/sys-apps/bzip2/files/digest-bzip2-1.0.1-r4 b/sys-apps/bzip2/files/digest-bzip2-1.0.1-r4
new file mode 100644
index 000000000000..4a2d8e5861de
--- /dev/null
+++ b/sys-apps/bzip2/files/digest-bzip2-1.0.1-r4
@@ -0,0 +1 @@
+MD5 770135dc94369cb3eb6013ed505c8dc5 bzip2-1.0.1.tar.gz
diff --git a/sys-apps/debianutils/debianutils-1.13.3-r4.ebuild b/sys-apps/debianutils/debianutils-1.13.3-r4.ebuild
new file mode 100644
index 000000000000..e5fe3e532c77
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-1.13.3-r4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.13.3-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A selection of tools from Debian"
+SRC_URI="ftp://ftp.debian.org/debian/dists/potato/main/source/base/debianutils_${PV}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+
+}
+
+src_compile() {
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static
+ fi
+}
+
+
+src_install() {
+
+ into /
+ dobin readlink tempfile mktemp
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dobin run-parts
+ insopts -m755
+ exeinto /usr/sbin
+ doexe savelog
+
+ doman mktemp.1 readlink.1 tempfile.1 run-parts.8 savelog.8
+
+ cd debian
+ dodoc changelog control copyright
+ fi
+
+}
+
+
+
diff --git a/sys-apps/debianutils/files/digest-debianutils-1.13.3-r4 b/sys-apps/debianutils/files/digest-debianutils-1.13.3-r4
new file mode 100644
index 000000000000..30079b8cc3cd
--- /dev/null
+++ b/sys-apps/debianutils/files/digest-debianutils-1.13.3-r4
@@ -0,0 +1 @@
+MD5 91511bc2eec9beebb23cf22fb57a202e debianutils_1.13.3.tar.gz
diff --git a/sys-apps/file/file-3.33-r3.ebuild b/sys-apps/file/file-3.33-r3.ebuild
new file mode 100644
index 000000000000..d3fde78e9cc1
--- /dev/null
+++ b/sys-apps/file/file-3.33-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
+#unfortunately, this ftp site doesn't support passive ftp
+#maybe we can find an alternative for those behind firewalls, or mirror
+#on cvs.gentoo.org
+SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/misc --host=${CHOST}
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc LEGAL.NOTICE MAINT README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
+}
+
+
+
diff --git a/sys-apps/file/files/digest-file-3.33-r3 b/sys-apps/file/files/digest-file-3.33-r3
new file mode 100644
index 000000000000..9a0e1f33e262
--- /dev/null
+++ b/sys-apps/file/files/digest-file-3.33-r3
@@ -0,0 +1 @@
+MD5 3b8e32ed3a79774bd92f0052fa07ca04 file-3.33.tar.gz
diff --git a/sys-apps/fileutils/files/digest-fileutils-4.1-r2 b/sys-apps/fileutils/files/digest-fileutils-4.1-r2
new file mode 100644
index 000000000000..d32a4e9fe3a1
--- /dev/null
+++ b/sys-apps/fileutils/files/digest-fileutils-4.1-r2
@@ -0,0 +1 @@
+MD5 2fa04ceee87e962ddf72f32a2d6b906d fileutils-4.1.tar.gz
diff --git a/sys-apps/fileutils/fileutils-4.1-r2.ebuild b/sys-apps/fileutils/fileutils-4.1-r2.ebuild
new file mode 100644
index 000000000000..557cd0b5a91d
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1-r2.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --bindir=/bin ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info bindir=${D}/bin install
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+ cd ${S}
+ dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
+ else
+ cd ${S}/src
+ into /
+ dobin chgrp chown dd dir du ln mkdir mknod rm touch \
+ chmod cp df ls mkfifo mv rmdir sync
+ newbin ginstall install
+ dosym /bin/install /usr/bin/install
+ fi
+
+}
+
diff --git a/sys-apps/findutils/files/digest-findutils-4.1-r6 b/sys-apps/findutils/files/digest-findutils-4.1-r6
new file mode 100644
index 000000000000..d959da1b7872
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.1-r6
@@ -0,0 +1 @@
+MD5 3ea8fe58ef5386da75f6c707713aa059 findutils-4.1.tar.gz
diff --git a/sys-apps/findutils/findutils-4.1-r6.ebuild b/sys-apps/findutils/findutils-4.1-r6.ebuild
new file mode 100644
index 000000000000..545b85c137ce
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1-r6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1-r6.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU utilities to find files"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/findutils/${A}
+ ftp://prep.ai.mit.edu/gnu/findutils/${A}"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+DEPEND="virtual/glibc sys-devel/gettext"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ echo "Applying Patch..."
+ #using sed to apply minor patches to files
+ cd ${S}
+
+ cd find
+ cp fstype.c fstype.c.orig
+ sed -e "33d" -e "34d" fstype.c.orig > fstype.c
+ cp parser.c parser.c.orig
+ sed -e "55d" parser.c.orig > parser.c
+ cp pred.c pred.c.orig
+ sed -e '29i\' -e '#define FNM_CASEFOLD (1<<4)' pred.c.orig > pred.c
+ cd ${S}/lib
+ cp nextelem.c nextelem.c.orig
+ sed -e "35d" nextelem.c.orig > nextelem.c
+ cd ${S}/xargs
+ cp xargs.c xargs.c.orig
+ sed -e "63d" -e "64d" xargs.c.orig > xargs.c
+}
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+
+ # do not use pmake recursive
+
+ if [ -z "`use static`" ]
+ then
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS
+ else
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info libexecdir=${D}/usr/lib/find \
+ LOCATE_DB=${D}/var/lib/misc/locatedb install
+ dosed "s:TMPDIR=/usr/tmp:TMPDIR=/tmp:" usr/bin/updatedb
+
+ rm -fr ${D}/usr/var
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -fr ${D}/usr/share
+ fi
+
+}
+
diff --git a/sys-apps/gawk/files/digest-gawk-3.0.6-r4 b/sys-apps/gawk/files/digest-gawk-3.0.6-r4
new file mode 100644
index 000000000000..55f7d10d4a37
--- /dev/null
+++ b/sys-apps/gawk/files/digest-gawk-3.0.6-r4
@@ -0,0 +1 @@
+MD5 b5ba21c033f5a9737455458d94954609 gawk-3.0.6.tar.gz
diff --git a/sys-apps/gawk/gawk-3.0.6-r4.ebuild b/sys-apps/gawk/gawk-3.0.6-r4.ebuild
new file mode 100644
index 000000000000..d8403962703e
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.0.6-r4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.0.6-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU awk pattern-matching language"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gawk/${A}
+ ftp://prep.ai.mit.edu/gnu/gawk/${A}"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --libexecdir=/usr/lib/awk --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info libexecdir=${D}/usr/lib/awk install
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc ChangeLog ACKNOWLEDGMENT COPYING FUTURES
+ dodoc LIMITATIONS NEWS PROBLEMS README
+ docinto README_d
+ dodoc README_d/*
+ docinto atari
+ dodoc atari/ChangeLog atari/README.1st
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+
+}
+
+
+
diff --git a/sys-apps/grep/files/digest-grep-2.4.2-r4 b/sys-apps/grep/files/digest-grep-2.4.2-r4
new file mode 100644
index 000000000000..10f2f727a071
--- /dev/null
+++ b/sys-apps/grep/files/digest-grep-2.4.2-r4
@@ -0,0 +1 @@
+MD5 8ec9a2e875cd3aaa89896a8f39249f58 grep-2.4.2.tar.gz
diff --git a/sys-apps/grep/grep-2.4.2-r4.ebuild b/sys-apps/grep/grep-2.4.2-r4.ebuild
new file mode 100644
index 000000000000..5c788728afab
--- /dev/null
+++ b/sys-apps/grep/grep-2.4.2-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.4.2-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU regular expression matcher"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/grep/${A}
+ ftp://prep.ai.mit.edu/gnu/grep/${A}"
+HOMEPAGE="http://www.gnu.org/software/grep/grep.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make LDFLAGS=-static ${MAKEOPTS}
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
+
+
+
diff --git a/sys-apps/gzip/files/digest-gzip-1.2.4a-r4 b/sys-apps/gzip/files/digest-gzip-1.2.4a-r4
new file mode 100644
index 000000000000..60ae475bc42e
--- /dev/null
+++ b/sys-apps/gzip/files/digest-gzip-1.2.4a-r4
@@ -0,0 +1 @@
+MD5 39053e044b18ecd0627f80fbe7cfeaad gzip-1.2.4a.tar.gz
diff --git a/sys-apps/gzip/gzip-1.2.4a-r4.ebuild b/sys-apps/gzip/gzip-1.2.4a-r4.ebuild
new file mode 100644
index 000000000000..633101a22282
--- /dev/null
+++ b/sys-apps/gzip/gzip-1.2.4a-r4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU compressor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
+ ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static ${MAKEOPTS}
+ fi
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/share/man/man1
+ try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
+
+ cd ${D}/bin
+ for i in gzexe zforce zgrep zmore znew zcmp
+ do
+ cp ${i} ${i}.orig
+ sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
+ rm ${i}.orig
+ chmod 755 ${i}
+ done
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ cd ${D}/usr/share/man/man1
+
+ for i in gzexe gzip zcat zcmp zdiff zforce \
+ zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
+}
+
+
+
+
diff --git a/sys-apps/portage/portage-1.5.2.ebuild b/sys-apps/portage/portage-1.5.2.ebuild
index 4e50d1dc99f3..604f1ce8da24 100644
--- a/sys-apps/portage/portage-1.5.2.ebuild
+++ b/sys-apps/portage/portage-1.5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.5.2.ebuild,v 1.1 2001/06/19 21:18:14 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.5.2.ebuild,v 1.2 2001/07/28 15:49:20 pete Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Portage autobuild system"
@@ -51,7 +51,7 @@ src_install() {
dosym /usr/lib/portage/bin/tbz2tool /usr/bin/tbz2tool
dosym newins /usr/lib/portage/bin/donewins
- if [ -z "`use build`" ]
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
then
#man pages
doman ${FILESDIR}/${PPV}/man/*.[15]
diff --git a/sys-apps/sed/files/digest-sed-3.02.80-r3 b/sys-apps/sed/files/digest-sed-3.02.80-r3
new file mode 100644
index 000000000000..c2922128b256
--- /dev/null
+++ b/sys-apps/sed/files/digest-sed-3.02.80-r3
@@ -0,0 +1 @@
+MD5 3bf4f42bc0a5f9345a7586a73be3df79 sed-3.02.80.tar.gz
diff --git a/sys-apps/sed/sed-3.02.80-r3.ebuild b/sys-apps/sed/sed-3.02.80-r3.ebuild
new file mode 100644
index 000000000000..c35d128af82a
--- /dev/null
+++ b/sys-apps/sed/sed-3.02.80-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Super-useful stream editor"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ into /
+ dobin sed/sed
+ dodir /usr/bin
+ dosym ../../bin/sed /usr/bin/sed
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ into /usr
+ doinfo doc/sed.info
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
+
diff --git a/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4 b/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4
new file mode 100644
index 000000000000..bc4f2b097953
--- /dev/null
+++ b/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4
@@ -0,0 +1 @@
+MD5 82087d6cc313189c312a0cf8ef875a2c sh-utils-2.0j.tar.gz
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
new file mode 100644
index 000000000000..c2853ea08510
--- /dev/null
+++ b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
@@ -0,0 +1,66 @@
+
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Your standard GNU shell utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-src-sys2.h-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try CFLAGS=\"${CFLAGS}\" ./configure --host=${CHOST} --build=${CHOST} \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ rm -rf ${D}/usr/lib
+ dodir /bin
+ cd ${D}/usr/bin
+ mv date echo false pwd stty su true uname ${D}/bin
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ # We must use hostname from net-base
+ rm hostname
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
+ NEWS README THANKS TODO
+ else
+ rm -rf ${D}/usr/lib ${D}/usr/share
+ fi
+
+}
+
+
+
diff --git a/sys-apps/tar/files/digest-tar-1.13.19-r1 b/sys-apps/tar/files/digest-tar-1.13.19-r1
new file mode 100644
index 000000000000..5c266195c6f9
--- /dev/null
+++ b/sys-apps/tar/files/digest-tar-1.13.19-r1
@@ -0,0 +1 @@
+MD5 ff10ade59f5b312869ffb2f229177e14 tar-1.13.19.tar.gz
diff --git a/sys-apps/tar/tar-1.13.19-r1.ebuild b/sys-apps/tar/tar-1.13.19-r1.ebuild
new file mode 100644
index 000000000000..aed64224a93d
--- /dev/null
+++ b/sys-apps/tar/tar-1.13.19-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.19-r1.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Use this to try make tarballs :)"
+SRC_URI="ftp://alpha.gnu.org/gnu/tar/"${A}
+HOMEPAGE="http://www.gnu.org/software/tar/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext-0.10.35 )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ patch -p0 < ${FILESDIR}/tar-1.13.19.patch
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --bindir=/bin --libexecdir=/usr/lib/misc \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+ try make DESTDIR=${D} install
+ #FHS 2.1 stuff
+ dodir /usr/sbin
+ cd ${D}
+ mv usr/lib/misc/rmt usr/sbin/rmt.gnu
+ dosym rmt.gnu /usr/sbin/rmt
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
+
+ #we're using Schilly's enhanced rmt command included with star
+# rm -rf ${D}/usr/lib
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
+
+
diff --git a/sys-apps/textutils/files/digest-textutils-2.0.10-r3 b/sys-apps/textutils/files/digest-textutils-2.0.10-r3
new file mode 100644
index 000000000000..1c652739479f
--- /dev/null
+++ b/sys-apps/textutils/files/digest-textutils-2.0.10-r3
@@ -0,0 +1 @@
+MD5 420a7cd54d4ce4b44c412af1318f7c83 textutils-2.0.10.tar.gz
diff --git a/sys-apps/textutils/textutils-2.0.10-r3.ebuild b/sys-apps/textutils/textutils-2.0.10-r3.ebuild
new file mode 100644
index 000000000000..0b674e1dd85d
--- /dev/null
+++ b/sys-apps/textutils/textutils-2.0.10-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/textutils-2.0.10-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU text utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --host=${CHOST} --build=${CHOST} --without-included-regex ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/cat ${D}/bin
+ dosym /bin/cat /usr/bin/cat
+ rmdir ${D}/usr/lib
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
diff --git a/sys-apps/util-linux/util-linux-2.11g.ebuild b/sys-apps/util-linux/util-linux-2.11g.ebuild
index aaa41483fb5c..16ae5152585c 100644
--- a/sys-apps/util-linux/util-linux-2.11g.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11g.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11g.ebuild,v 1.1 2001/07/10 06:46:44 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11g.ebuild,v 1.2 2001/07/28 15:49:20 pete Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Various useful Linux utilities"
@@ -17,7 +17,7 @@ src_unpack() {
unpack ${P}.tar.gz
cd ${S}
cp MCONFIG MCONFIG.orig
- sed -e "s:-pipe -O2 $(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
+ sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
-e "s:CPU=.*:CPU=${CHOST%%-*}:" \
-e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
-e "s:HAVE_SLN=no:HAVE_SLN=yes:" \