summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-20 08:16:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-20 08:16:00 +0000
commit30971c4f8ab4c65fb4eb28ce276f7375edf3a01e (patch)
tree3d7ea539ebbdb7d10e2f4756e1d1b037cd7e41ce /sys-apps/sed
parentdocument (diff)
downloadgentoo-2-30971c4f8ab4c65fb4eb28ce276f7375edf3a01e.tar.gz
gentoo-2-30971c4f8ab4c65fb4eb28ce276f7375edf3a01e.tar.bz2
gentoo-2-30971c4f8ab4c65fb4eb28ce276f7375edf3a01e.zip
Version bump #270530 by Lars Wendler.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog9
-rw-r--r--sys-apps/sed/sed-4.2.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 60c1e8746e01..fa156d8da508 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sed
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.90 2008/03/29 16:45:30 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.91 2009/05/20 08:16:00 vapier Exp $
+
+*sed-4.2 (20 May 2009)
+
+ 20 May 2009; Mike Frysinger <vapier@gentoo.org> +sed-4.2.ebuild:
+ Version bump #270530 by Lars Wendler.
29 Mar 2008; Raúl Porcel <armin76@gentoo.org> sed-4.1.5-r1.ebuild:
alpha/ia64/sparc stable wrt #215072
diff --git a/sys-apps/sed/sed-4.2.ebuild b/sys-apps/sed/sed-4.2.ebuild
new file mode 100644
index 000000000000..9b81d5dad242
--- /dev/null
+++ b/sys-apps/sed/sed-4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.2.ebuild,v 1.1 2009/05/20 08:16:00 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! type -p sed > /dev/null ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed "${T}"/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ make clean || die "couldnt clean"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
+ # don't use sed here if we have to recover a broken host sed
+}
+
+src_compile() {
+ src_bootstrap_sed
+ # this has to be after the bootstrap portion
+ sed -i \
+ -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
+ doc/Makefile.in || die "sed html doc"
+
+ local myconf= bindir=/bin
+ if ! use userland_GNU ; then
+ myconf="--program-prefix=g"
+ bindir=/usr/bin
+ fi
+
+ use static && append-ldflags -static
+ econf \
+ --bindir=${bindir} \
+ $(use_enable nls) \
+ ${myconf}
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
+ docinto examples
+ dodoc "${FILESDIR}"/{dos2unix,unix2dos}
+}