summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit00370f2de9e5825d29ca212d51ed35388567b48d (patch)
treefbd98eac91baf6271f55be3aa165475eae5ce777 /sys-apps/findutils
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadgentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.gz
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.bz2
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.1-r61
-rw-r--r--sys-apps/findutils/findutils-4.1-r6.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/findutils/files/digest-findutils-4.1-r6 b/sys-apps/findutils/files/digest-findutils-4.1-r6
new file mode 100644
index 000000000000..d959da1b7872
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.1-r6
@@ -0,0 +1 @@
+MD5 3ea8fe58ef5386da75f6c707713aa059 findutils-4.1.tar.gz
diff --git a/sys-apps/findutils/findutils-4.1-r6.ebuild b/sys-apps/findutils/findutils-4.1-r6.ebuild
new file mode 100644
index 000000000000..545b85c137ce
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1-r6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1-r6.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU utilities to find files"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/findutils/${A}
+ ftp://prep.ai.mit.edu/gnu/findutils/${A}"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+DEPEND="virtual/glibc sys-devel/gettext"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ echo "Applying Patch..."
+ #using sed to apply minor patches to files
+ cd ${S}
+
+ cd find
+ cp fstype.c fstype.c.orig
+ sed -e "33d" -e "34d" fstype.c.orig > fstype.c
+ cp parser.c parser.c.orig
+ sed -e "55d" parser.c.orig > parser.c
+ cp pred.c pred.c.orig
+ sed -e '29i\' -e '#define FNM_CASEFOLD (1<<4)' pred.c.orig > pred.c
+ cd ${S}/lib
+ cp nextelem.c nextelem.c.orig
+ sed -e "35d" nextelem.c.orig > nextelem.c
+ cd ${S}/xargs
+ cp xargs.c xargs.c.orig
+ sed -e "63d" -e "64d" xargs.c.orig > xargs.c
+}
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+
+ # do not use pmake recursive
+
+ if [ -z "`use static`" ]
+ then
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS
+ else
+ try make LOCATE_DB=/var/lib/misc/locatedb \
+ libexecdir=/usr/lib/find $MAKEOPTS LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info libexecdir=${D}/usr/lib/find \
+ LOCATE_DB=${D}/var/lib/misc/locatedb install
+ dosed "s:TMPDIR=/usr/tmp:TMPDIR=/tmp:" usr/bin/updatedb
+
+ rm -fr ${D}/usr/var
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -fr ${D}/usr/share
+ fi
+
+}
+