summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-02 21:04:22 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-02 21:04:22 +0000
commitac503901f3a7d93c604e1c320cd27fc7927bcd00 (patch)
treea121653956d442ffed7f082c4fe6ca9e6e8bc6c9 /sys-apps/dmidecode
parentAdd ~sparc keyword, bug #253448 (diff)
downloadgentoo-2-ac503901f3a7d93c604e1c320cd27fc7927bcd00.tar.gz
gentoo-2-ac503901f3a7d93c604e1c320cd27fc7927bcd00.tar.bz2
gentoo-2-ac503901f3a7d93c604e1c320cd27fc7927bcd00.zip
Version bump #253222 by Bruno.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/ChangeLog9
-rw-r--r--sys-apps/dmidecode/dmidecode-2.10.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/sys-apps/dmidecode/ChangeLog b/sys-apps/dmidecode/ChangeLog
index f4b30baa8235..bb982d31b67a 100644
--- a/sys-apps/dmidecode/ChangeLog
+++ b/sys-apps/dmidecode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dmidecode
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.23 2008/01/29 16:59:07 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.24 2009/01/02 21:04:22 vapier Exp $
+
+*dmidecode-2.10 (02 Jan 2009)
+
+ 02 Jan 2009; Mike Frysinger <vapier@gentoo.org> +dmidecode-2.10.ebuild:
+ Version bump #253222 by Bruno.
29 Jan 2008; nixnut <nixnut@gentoo.org> dmidecode-2.9.ebuild:
Adding ~ppc
diff --git a/sys-apps/dmidecode/dmidecode-2.10.ebuild b/sys-apps/dmidecode/dmidecode-2.10.ebuild
new file mode 100644
index 000000000000..ea16675ba9a2
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.10.ebuild,v 1.1 2009/01/02 21:04:22 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/dmidecode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^prefix/s:/usr/local:/usr:' \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ Makefile || die "manpage sed failed"
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ prepalldocs
+}