summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-2.10.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-2.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-2.10.ebuild b/sys-apps/dmidecode/dmidecode-2.10.ebuild
new file mode 100644
index 000000000000..ea16675ba9a2
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.10.ebuild,v 1.1 2009/01/02 21:04:22 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/dmidecode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^prefix/s:/usr/local:/usr:' \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ Makefile || die "manpage sed failed"
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ prepalldocs
+}