summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-03 19:53:42 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-03 19:53:42 +0000
commit7abb7ba9820c44888ea28f1ecadfb02d48e0d11a (patch)
treee54afd8d6017141a0f9827d314f32c77eda3b94e /sys-apps/coreutils
parentVersion bump. (diff)
downloadgentoo-2-7abb7ba9820c44888ea28f1ecadfb02d48e0d11a.tar.gz
gentoo-2-7abb7ba9820c44888ea28f1ecadfb02d48e0d11a.tar.bz2
gentoo-2-7abb7ba9820c44888ea28f1ecadfb02d48e0d11a.zip
Workaround broken --enable-libcap handling #283589 by Alberto.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog6
-rw-r--r--sys-apps/coreutils/coreutils-7.1.ebuild4
-rw-r--r--sys-apps/coreutils/coreutils-7.2.ebuild4
-rw-r--r--sys-apps/coreutils/coreutils-7.4.ebuild4
-rw-r--r--sys-apps/coreutils/coreutils-7.5.ebuild4
5 files changed, 13 insertions, 9 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 2e5f79929c2d..e964355a9fc1 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.264 2009/08/31 00:31:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.265 2009/09/03 19:53:42 vapier Exp $
+
+ 03 Sep 2009; Mike Frysinger <vapier@gentoo.org> coreutils-7.1.ebuild,
+ coreutils-7.2.ebuild, coreutils-7.4.ebuild, coreutils-7.5.ebuild:
+ Workaround broken --enable-libcap handling #283589 by Alberto.
31 Aug 2009; Brent Baude <ranger@gentoo.org> coreutils-7.4.ebuild:
stable ppc64, bug 281699
diff --git a/sys-apps/coreutils/coreutils-7.1.ebuild b/sys-apps/coreutils/coreutils-7.1.ebuild
index b200c7634bc1..7a0ce99453ad 100644
--- a/sys-apps/coreutils/coreutils-7.1.ebuild
+++ b/sys-apps/coreutils/coreutils-7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.1.ebuild,v 1.19 2009/08/16 18:37:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.1.ebuild,v 1.20 2009/09/03 19:53:42 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -64,7 +64,7 @@ src_compile() {
--enable-install-program="arch" \
--enable-no-install-program="groups,hostname,kill,su,uptime" \
--enable-largefile \
- $(use_enable caps libcap) \
+ $(use caps || echo --disable-libcap) \
$(use_enable nls) \
$(use_enable acl) \
$(use_enable xattr) \
diff --git a/sys-apps/coreutils/coreutils-7.2.ebuild b/sys-apps/coreutils/coreutils-7.2.ebuild
index 1363306c6cb3..221b0ef2ca5e 100644
--- a/sys-apps/coreutils/coreutils-7.2.ebuild
+++ b/sys-apps/coreutils/coreutils-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.2.ebuild,v 1.6 2009/08/16 18:37:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.2.ebuild,v 1.7 2009/09/03 19:53:42 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -64,7 +64,7 @@ src_compile() {
--enable-install-program="arch" \
--enable-no-install-program="groups,hostname,kill,su,uptime" \
--enable-largefile \
- $(use_enable caps libcap) \
+ $(use caps || echo --disable-libcap) \
$(use_enable nls) \
$(use_enable acl) \
$(use_enable xattr) \
diff --git a/sys-apps/coreutils/coreutils-7.4.ebuild b/sys-apps/coreutils/coreutils-7.4.ebuild
index 9640c9ed6b22..35ad1071ed4a 100644
--- a/sys-apps/coreutils/coreutils-7.4.ebuild
+++ b/sys-apps/coreutils/coreutils-7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.4.ebuild,v 1.10 2009/08/31 00:31:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.4.ebuild,v 1.11 2009/09/03 19:53:42 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -64,7 +64,7 @@ src_compile() {
--enable-install-program="arch" \
--enable-no-install-program="groups,hostname,kill,su,uptime" \
--enable-largefile \
- $(use_enable caps libcap) \
+ $(use caps || echo --disable-libcap) \
$(use_enable nls) \
$(use_enable acl) \
$(use_enable xattr) \
diff --git a/sys-apps/coreutils/coreutils-7.5.ebuild b/sys-apps/coreutils/coreutils-7.5.ebuild
index c523ee161804..f2539ba25a52 100644
--- a/sys-apps/coreutils/coreutils-7.5.ebuild
+++ b/sys-apps/coreutils/coreutils-7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.5.ebuild,v 1.1 2009/08/20 21:57:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-7.5.ebuild,v 1.2 2009/09/03 19:53:42 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -64,7 +64,7 @@ src_compile() {
--enable-install-program="arch" \
--enable-no-install-program="groups,hostname,kill,su,uptime" \
--enable-largefile \
- $(use_enable caps libcap) \
+ $(use caps || echo --disable-libcap) \
$(use_enable nls) \
$(use_enable acl) \
$(use_enable xattr) \