summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-17 11:53:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-17 11:53:52 +0000
commit6dbc00b92c500aab62799754abf1acd667e68898 (patch)
tree3a3aa6001aa6b6aff1840a2295e829433e00bc7c /sci-physics/bullet/files
parentRemove stale 3.0 version. (diff)
downloadgentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.tar.gz
gentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.tar.bz2
gentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.zip
Version Bump, backport fix for gcc46 problems, #363223
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/bullet/files')
-rw-r--r--sci-physics/bullet/files/bullet-2.77-gcc46.patch47
-rw-r--r--sci-physics/bullet/files/bullet-2.78-soversion.patch44
2 files changed, 91 insertions, 0 deletions
diff --git a/sci-physics/bullet/files/bullet-2.77-gcc46.patch b/sci-physics/bullet/files/bullet-2.77-gcc46.patch
new file mode 100644
index 000000000000..9ef054836e33
--- /dev/null
+++ b/sci-physics/bullet/files/bullet-2.77-gcc46.patch
@@ -0,0 +1,47 @@
+ src/BulletSoftBody/btSoftBody.h | 3 +++
+ src/BulletSoftBody/btSoftBodyInternals.h | 4 ++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/BulletSoftBody/btSoftBody.h b/src/BulletSoftBody/btSoftBody.h
+index 4d975b7..f781598 100644
+--- a/src/BulletSoftBody/btSoftBody.h
++++ b/src/BulletSoftBody/btSoftBody.h
+@@ -30,6 +30,7 @@ subject to the following restrictions:
+ class btBroadphaseInterface;
+ class btDispatcher;
+
++class btSoftBodySolver;
+
+ /* btSoftBodyWorldInfo */
+ struct btSoftBodyWorldInfo
+@@ -52,6 +53,8 @@ class btSoftBody : public btCollisionObject
+ public:
+ btAlignedObjectArray<class btCollisionObject*> m_collisionDisabledObjects;
+
++ // The solver object that handles this soft body
++ btSoftBodySolver *m_softBodySolver;
+ //
+ // Enumerations
+ //
+diff --git a/src/BulletSoftBody/btSoftBodyInternals.h b/src/BulletSoftBody/btSoftBodyInternals.h
+index 2cb7744..296d97a 100644
+--- a/src/BulletSoftBody/btSoftBodyInternals.h
++++ b/src/BulletSoftBody/btSoftBodyInternals.h
+@@ -26,6 +26,7 @@ subject to the following restrictions:
+ #include "BulletCollision/CollisionShapes/btConvexInternalShape.h"
+ #include "BulletCollision/NarrowPhaseCollision/btGjkEpa2.h"
+
++#include <string.h> //for memset
+ //
+ // btSymMatrix
+ //
+@@ -172,8 +173,7 @@ public:
+ template <typename T>
+ static inline void ZeroInitialize(T& value)
+ {
+- static const T zerodummy;
+- value=zerodummy;
++ memset(&value,0,sizeof(T));
+ }
+ //
+ template <typename T>
diff --git a/sci-physics/bullet/files/bullet-2.78-soversion.patch b/sci-physics/bullet/files/bullet-2.78-soversion.patch
new file mode 100644
index 000000000000..b54ffa777ee3
--- /dev/null
+++ b/sci-physics/bullet/files/bullet-2.78-soversion.patch
@@ -0,0 +1,44 @@
+ Extras/Serialize/BulletFileLoader/CMakeLists.txt | 2 ++
+ .../Serialize/BulletWorldImporter/CMakeLists.txt | 2 ++
+ Extras/glui/CMakeLists.txt | 2 ++
+ 3 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/Extras/Serialize/BulletFileLoader/CMakeLists.txt b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
+index 486cfdc..f1e0884 100644
+--- a/Extras/Serialize/BulletFileLoader/CMakeLists.txt
++++ b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
+@@ -16,6 +16,8 @@ btBulletFile.cpp
+ btBulletFile.h
+ )
+
++SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(BulletFileLoader LinearMath)
+ ENDIF (BUILD_SHARED_LIBS)
+diff --git a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
+index e620315..e04e8e9 100644
+--- a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
++++ b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
+@@ -9,6 +9,8 @@ btBulletWorldImporter.cpp
+ btBulletWorldImporter.h
+ )
+
++SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(BulletWorldImporter BulletDynamics BulletCollision BulletFileLoader LinearMath)
+ ENDIF (BUILD_SHARED_LIBS)
+diff --git a/Extras/glui/CMakeLists.txt b/Extras/glui/CMakeLists.txt
+index c2018a7..9a8d90f 100644
+--- a/Extras/glui/CMakeLists.txt
++++ b/Extras/glui/CMakeLists.txt
+@@ -61,6 +61,8 @@ arcball.cpp glui_button.cpp glui_filebrowser.cpp glui_node.cpp glui_separ
+
+ )
+
++SET_TARGET_PROPERTIES(GLUI PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(GLUI PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(GLUI ${GLUT_glut_LIBRARY} ${OPENGL_gl_LIBRARY} ${OPENGL_glu_LIBRARY})
+ ENDIF (BUILD_SHARED_LIBS)