summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-17 11:53:52 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-17 11:53:52 +0000
commit6dbc00b92c500aab62799754abf1acd667e68898 (patch)
tree3a3aa6001aa6b6aff1840a2295e829433e00bc7c
parentRemove stale 3.0 version. (diff)
downloadgentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.tar.gz
gentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.tar.bz2
gentoo-2-6dbc00b92c500aab62799754abf1acd667e68898.zip
Version Bump, backport fix for gcc46 problems, #363223
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
-rw-r--r--sci-physics/bullet/ChangeLog9
-rw-r--r--sci-physics/bullet/bullet-2.77.ebuild14
-rw-r--r--sci-physics/bullet/bullet-2.78.ebuild51
-rw-r--r--sci-physics/bullet/files/bullet-2.77-gcc46.patch47
-rw-r--r--sci-physics/bullet/files/bullet-2.78-soversion.patch44
5 files changed, 160 insertions, 5 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index 558784bb8e4b..4dc1466d5800 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.22 2011/03/22 17:10:29 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.23 2011/04/17 11:53:52 jlec Exp $
+
+*bullet-2.78 (17 Apr 2011)
+
+ 17 Apr 2011; Justin Lecher <jlec@gentoo.org> bullet-2.77.ebuild,
+ +files/bullet-2.77-gcc46.patch, +bullet-2.78.ebuild,
+ +files/bullet-2.78-soversion.patch:
+ Version Bump, backport fix for gcc46 problems, #363223
22 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> -bullet-2.76-r1.ebuild,
bullet-2.77.ebuild, metadata.xml:
diff --git a/sci-physics/bullet/bullet-2.77.ebuild b/sci-physics/bullet/bullet-2.77.ebuild
index 0a5b1a550773..04adc9e298f8 100644
--- a/sci-physics/bullet/bullet-2.77.ebuild
+++ b/sci-physics/bullet/bullet-2.77.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.77.ebuild,v 1.5 2011/03/22 17:10:29 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.77.ebuild,v 1.6 2011/04/17 11:53:52 jlec Exp $
EAPI=2
+
inherit eutils cmake-utils
DESCRIPTION="Continuous Collision Detection and Physics Library"
@@ -14,10 +15,15 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux"
IUSE="doc double-precision examples extras"
-RDEPEND="virtual/opengl
- media-libs/freeglut"
+RDEPEND="
+ media-libs/freeglut
+ virtual/opengl"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}"-{libdir,soversion}.patch )
+
+PATCHES=(
+ "${FILESDIR}/${P}"-{libdir,soversion}.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+ )
src_configure() {
mycmakeargs=(
diff --git a/sci-physics/bullet/bullet-2.78.ebuild b/sci-physics/bullet/bullet-2.78.ebuild
new file mode 100644
index 000000000000..c7f369f51558
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.78.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.78.ebuild,v 1.1 2011/04/17 11:53:52 jlec Exp $
+
+EAPI=2
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="http://bullet.googlecode.com/files/${P}-r2387.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc double-precision examples extras"
+
+RDEPEND="
+ media-libs/freeglut
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-soversion.patch
+ )
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_DEMOS=OFF
+ -DINSTALL_LIBS=ON
+ -DINSTALL_EXTRA_LIBS=ON
+ $(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README ChangeLog AUTHORS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras Demos || die
+ fi
+}
diff --git a/sci-physics/bullet/files/bullet-2.77-gcc46.patch b/sci-physics/bullet/files/bullet-2.77-gcc46.patch
new file mode 100644
index 000000000000..9ef054836e33
--- /dev/null
+++ b/sci-physics/bullet/files/bullet-2.77-gcc46.patch
@@ -0,0 +1,47 @@
+ src/BulletSoftBody/btSoftBody.h | 3 +++
+ src/BulletSoftBody/btSoftBodyInternals.h | 4 ++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/BulletSoftBody/btSoftBody.h b/src/BulletSoftBody/btSoftBody.h
+index 4d975b7..f781598 100644
+--- a/src/BulletSoftBody/btSoftBody.h
++++ b/src/BulletSoftBody/btSoftBody.h
+@@ -30,6 +30,7 @@ subject to the following restrictions:
+ class btBroadphaseInterface;
+ class btDispatcher;
+
++class btSoftBodySolver;
+
+ /* btSoftBodyWorldInfo */
+ struct btSoftBodyWorldInfo
+@@ -52,6 +53,8 @@ class btSoftBody : public btCollisionObject
+ public:
+ btAlignedObjectArray<class btCollisionObject*> m_collisionDisabledObjects;
+
++ // The solver object that handles this soft body
++ btSoftBodySolver *m_softBodySolver;
+ //
+ // Enumerations
+ //
+diff --git a/src/BulletSoftBody/btSoftBodyInternals.h b/src/BulletSoftBody/btSoftBodyInternals.h
+index 2cb7744..296d97a 100644
+--- a/src/BulletSoftBody/btSoftBodyInternals.h
++++ b/src/BulletSoftBody/btSoftBodyInternals.h
+@@ -26,6 +26,7 @@ subject to the following restrictions:
+ #include "BulletCollision/CollisionShapes/btConvexInternalShape.h"
+ #include "BulletCollision/NarrowPhaseCollision/btGjkEpa2.h"
+
++#include <string.h> //for memset
+ //
+ // btSymMatrix
+ //
+@@ -172,8 +173,7 @@ public:
+ template <typename T>
+ static inline void ZeroInitialize(T& value)
+ {
+- static const T zerodummy;
+- value=zerodummy;
++ memset(&value,0,sizeof(T));
+ }
+ //
+ template <typename T>
diff --git a/sci-physics/bullet/files/bullet-2.78-soversion.patch b/sci-physics/bullet/files/bullet-2.78-soversion.patch
new file mode 100644
index 000000000000..b54ffa777ee3
--- /dev/null
+++ b/sci-physics/bullet/files/bullet-2.78-soversion.patch
@@ -0,0 +1,44 @@
+ Extras/Serialize/BulletFileLoader/CMakeLists.txt | 2 ++
+ .../Serialize/BulletWorldImporter/CMakeLists.txt | 2 ++
+ Extras/glui/CMakeLists.txt | 2 ++
+ 3 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/Extras/Serialize/BulletFileLoader/CMakeLists.txt b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
+index 486cfdc..f1e0884 100644
+--- a/Extras/Serialize/BulletFileLoader/CMakeLists.txt
++++ b/Extras/Serialize/BulletFileLoader/CMakeLists.txt
+@@ -16,6 +16,8 @@ btBulletFile.cpp
+ btBulletFile.h
+ )
+
++SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(BulletFileLoader PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(BulletFileLoader LinearMath)
+ ENDIF (BUILD_SHARED_LIBS)
+diff --git a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
+index e620315..e04e8e9 100644
+--- a/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
++++ b/Extras/Serialize/BulletWorldImporter/CMakeLists.txt
+@@ -9,6 +9,8 @@ btBulletWorldImporter.cpp
+ btBulletWorldImporter.h
+ )
+
++SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(BulletWorldImporter PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(BulletWorldImporter BulletDynamics BulletCollision BulletFileLoader LinearMath)
+ ENDIF (BUILD_SHARED_LIBS)
+diff --git a/Extras/glui/CMakeLists.txt b/Extras/glui/CMakeLists.txt
+index c2018a7..9a8d90f 100644
+--- a/Extras/glui/CMakeLists.txt
++++ b/Extras/glui/CMakeLists.txt
+@@ -61,6 +61,8 @@ arcball.cpp glui_button.cpp glui_filebrowser.cpp glui_node.cpp glui_separ
+
+ )
+
++SET_TARGET_PROPERTIES(GLUI PROPERTIES VERSION ${BULLET_VERSION})
++SET_TARGET_PROPERTIES(GLUI PROPERTIES SOVERSION ${BULLET_VERSION})
+ IF (BUILD_SHARED_LIBS)
+ TARGET_LINK_LIBRARIES(GLUI ${GLUT_glut_LIBRARY} ${OPENGL_gl_LIBRARY} ${OPENGL_glu_LIBRARY})
+ ENDIF (BUILD_SHARED_LIBS)