summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-04-17 19:04:17 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-04-17 19:04:17 +0000
commit3930a5b662a68610c29921150c9630d2afed7878 (patch)
tree2d02e62062791dce117ca2c171b12b8e4398702a /sci-misc
parentStable on ppc wrt bug 217410 (diff)
downloadgentoo-2-3930a5b662a68610c29921150c9630d2afed7878.tar.gz
gentoo-2-3930a5b662a68610c29921150c9630d2afed7878.tar.bz2
gentoo-2-3930a5b662a68610c29921150c9630d2afed7878.zip
Added patch to fix compile problems with gcc-4.3 (see bug #217919).
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog9
-rw-r--r--sci-misc/boinc/boinc-4.72.20050813-r3.ebuild12
-rw-r--r--sci-misc/boinc/boinc-5.10.28.ebuild6
-rw-r--r--sci-misc/boinc/boinc-5.10.45.ebuild7
-rw-r--r--sci-misc/boinc/boinc-5.2.14.ebuild14
-rw-r--r--sci-misc/boinc/boinc-5.4.11.ebuild10
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild10
-rw-r--r--sci-misc/boinc/files/boinc-5.10.45-gcc4.3.patch55
8 files changed, 93 insertions, 30 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 2c13f9f69eee..575849069d22 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.38 2008/04/15 18:48:46 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.39 2008/04/17 19:04:16 markusle Exp $
+
+ 17 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/boinc-5.10.45-gcc4.3.patch, boinc-4.72.20050813-r3.ebuild,
+ boinc-5.2.14.ebuild, boinc-5.4.11.ebuild, boinc-5.5.6.ebuild,
+ boinc-5.10.28.ebuild, boinc-5.10.45.ebuild:
+ Added patch to fix compile problems with gcc-4.3 (see bug #217919).
+ Fixed lots of QA issues.
*boinc-5.10.45 (15 Apr 2008)
diff --git a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
index 4dcb9bb13605..08a6a4637b3a 100644
--- a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
+++ b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.12 2008/02/05 15:36:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.13 2008/04/17 19:04:16 markusle Exp $
inherit eutils wxwidgets depend.apache
@@ -40,10 +40,10 @@ want_apache server
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# GCC 4 patch, bug 112133.
- epatch ${FILESDIR}/${P}-gcc4-fix.patch
+ epatch "${FILESDIR}"/${P}-gcc4-fix.patch
# point to a proper mouse device
sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
@@ -66,10 +66,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
+ newinitd "${FILESDIR}"/boinc.init boinc
+ newconfd "${FILESDIR}"/boinc.conf boinc
make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
}
diff --git a/sci-misc/boinc/boinc-5.10.28.ebuild b/sci-misc/boinc/boinc-5.10.28.ebuild
index 8f3a190b05fd..cabe05bc0091 100644
--- a/sci-misc/boinc/boinc-5.10.28.ebuild
+++ b/sci-misc/boinc/boinc-5.10.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.28.ebuild,v 1.2 2008/02/05 15:36:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.28.ebuild,v 1.3 2008/04/17 19:04:16 markusle Exp $
inherit flag-o-matic wxwidgets depend.apache
@@ -39,8 +39,8 @@ DEPEND=">=sys-devel/gcc-3.0.4
want_apache server
src_unpack() {
- unpack "${A}"
- cd ""${S}""
+ unpack ${A}
+ cd "${S}"
}
src_compile() {
diff --git a/sci-misc/boinc/boinc-5.10.45.ebuild b/sci-misc/boinc/boinc-5.10.45.ebuild
index 0a4e4690c09b..676c266970d4 100644
--- a/sci-misc/boinc/boinc-5.10.45.ebuild
+++ b/sci-misc/boinc/boinc-5.10.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.45.ebuild,v 1.1 2008/04/15 18:48:46 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.10.45.ebuild,v 1.2 2008/04/17 19:04:16 markusle Exp $
inherit flag-o-matic wxwidgets depend.apache
@@ -39,8 +39,9 @@ DEPEND=">=sys-devel/gcc-3.0.4
want_apache server
src_unpack() {
- unpack "${A}"
- cd ""${S}""
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
}
src_compile() {
diff --git a/sci-misc/boinc/boinc-5.2.14.ebuild b/sci-misc/boinc/boinc-5.2.14.ebuild
index 430788c3b8ea..8f110304ea3b 100644
--- a/sci-misc/boinc/boinc-5.2.14.ebuild
+++ b/sci-misc/boinc/boinc-5.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.14 2008/02/05 15:36:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.15 2008/04/17 19:04:16 markusle Exp $
inherit eutils wxwidgets depend.apache
@@ -39,12 +39,12 @@ want_apache server
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Apply patches, most of which from Debian
EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
- epatch ${FILESDIR}/08_all_Makefile.patch
- epatch ${FILESDIR}/${P}-gcc-4.1.patch
+ epatch "${FILESDIR}"/08_all_Makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.1.patch
# point to a proper mouse device
sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
@@ -72,10 +72,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
+ newinitd "${FILESDIR}"/boinc.init boinc
+ newconfd "${FILESDIR}"/boinc.conf boinc
make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
}
diff --git a/sci-misc/boinc/boinc-5.4.11.ebuild b/sci-misc/boinc/boinc-5.4.11.ebuild
index b9f102ff828b..867b756a10af 100644
--- a/sci-misc/boinc/boinc-5.4.11.ebuild
+++ b/sci-misc/boinc/boinc-5.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.9 2008/02/05 15:36:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.10 2008/04/17 19:04:16 markusle Exp $
inherit eutils wxwidgets depend.apache
@@ -40,7 +40,7 @@ want_apache server
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# point to a proper mouse device
sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
@@ -72,10 +72,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
+ newinitd "${FILESDIR}"/boinc.init boinc
+ newconfd "${FILESDIR}"/boinc.conf boinc
make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
}
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
index 1f7108a9cefb..6e26d6865773 100644
--- a/sci-misc/boinc/boinc-5.5.6.ebuild
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.12 2008/02/05 15:36:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.13 2008/04/17 19:04:16 markusle Exp $
inherit eutils wxwidgets depend.apache
@@ -40,7 +40,7 @@ want_apache server
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# point to a proper mouse device
sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
@@ -78,10 +78,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
- newinitd ${FILESDIR}/boinc.init boinc
- newconfd ${FILESDIR}/boinc.conf boinc
+ newinitd "${FILESDIR}"/boinc.init boinc
+ newconfd "${FILESDIR}"/boinc.conf boinc
make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
}
diff --git a/sci-misc/boinc/files/boinc-5.10.45-gcc4.3.patch b/sci-misc/boinc/files/boinc-5.10.45-gcc4.3.patch
new file mode 100644
index 000000000000..778d016419e3
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-5.10.45-gcc4.3.patch
@@ -0,0 +1,55 @@
+diff -Naur boinc-5.10.45/client/client_msgs.C boinc-5.10.45.new/client/client_msgs.C
+--- boinc-5.10.45/client/client_msgs.C 2008-04-15 13:20:37.000000000 -0400
++++ boinc-5.10.45.new/client/client_msgs.C 2008-04-17 14:26:48.000000000 -0400
+@@ -27,6 +27,7 @@
+
+ using std::deque;
+
++#include <cstring>
+ #include "log_flags.h"
+ #include "client_types.h"
+ #include "client_msgs.h"
+diff -Naur boinc-5.10.45/client/cs_account.C boinc-5.10.45.new/client/cs_account.C
+--- boinc-5.10.45/client/cs_account.C 2008-04-15 13:20:36.000000000 -0400
++++ boinc-5.10.45.new/client/cs_account.C 2008-04-17 14:28:19.000000000 -0400
+@@ -30,6 +30,7 @@
+ #endif
+ #endif
+
++#include <algorithm>
+ #include "filesys.h"
+ #include "parse.h"
+ #include "str_util.h"
+diff -Naur boinc-5.10.45/lib/crypt.C boinc-5.10.45.new/lib/crypt.C
+--- boinc-5.10.45/lib/crypt.C 2008-04-15 13:19:19.000000000 -0400
++++ boinc-5.10.45.new/lib/crypt.C 2008-04-17 14:24:26.000000000 -0400
+@@ -28,6 +28,7 @@
+ #include <cstdlib>
+ #endif
+
++#include <cstring>
+ #include "md5_file.h"
+ #include "error_numbers.h"
+
+diff -Naur boinc-5.10.45/lib/parse.h boinc-5.10.45.new/lib/parse.h
+--- boinc-5.10.45/lib/parse.h 2008-04-15 13:19:19.000000000 -0400
++++ boinc-5.10.45.new/lib/parse.h 2008-04-17 14:23:30.000000000 -0400
+@@ -27,6 +27,7 @@
+ #include <cstdlib>
+ #include <string>
+ #include <math.h>
++#include <cstring>
+ #ifdef solaris
+ #include <ieeefp.h>
+ #endif
+diff -Naur boinc-5.10.45/lib/procinfo_unix.C boinc-5.10.45.new/lib/procinfo_unix.C
+--- boinc-5.10.45/lib/procinfo_unix.C 2008-04-15 13:19:19.000000000 -0400
++++ boinc-5.10.45.new/lib/procinfo_unix.C 2008-04-17 14:25:30.000000000 -0400
+@@ -29,6 +29,7 @@
+
+ #include <stdio.h>
+
++#include <cstring>
+ #include <ctype.h>
+ #include <sys/types.h>
+ #include <dirent.h>