summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:18:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:18:55 +0000
commitc1a518439a0c31591e616e822cdce5a999aa2b5d (patch)
tree54885211aa870698a9bb8887b5a7999c6171d6dd /sci-mathematics/fann/fann-2.2.0.ebuild
parent[bump] dev-perl/IO-Socket-SSL-1.700.0 (diff)
downloadgentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.tar.gz
gentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.tar.bz2
gentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.zip
Version bump. Optimize python module only when python is selected (bug #356975)
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/fann/fann-2.2.0.ebuild')
-rw-r--r--sci-mathematics/fann/fann-2.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/fann/fann-2.2.0.ebuild b/sci-mathematics/fann/fann-2.2.0.ebuild
new file mode 100644
index 000000000000..35972a59eeb4
--- /dev/null
+++ b/sci-mathematics/fann/fann-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.2.0.ebuild,v 1.1 2012/05/08 18:18:55 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+MYP=FANN-${PV}-Source
+
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${P}-examples.patch )
+
+src_test() {
+ cd examples
+ emake CFLAGS="${CFLAGS} -I../src/include -L${BUILD_DIR}/src"
+ LD_LIBRARY_PATH="${BUILD_DIR}/src" emake runtest
+ emake clean
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}