summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:18:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-05-08 18:18:55 +0000
commitc1a518439a0c31591e616e822cdce5a999aa2b5d (patch)
tree54885211aa870698a9bb8887b5a7999c6171d6dd
parent[bump] dev-perl/IO-Socket-SSL-1.700.0 (diff)
downloadgentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.tar.gz
gentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.tar.bz2
gentoo-2-c1a518439a0c31591e616e822cdce5a999aa2b5d.zip
Version bump. Optimize python module only when python is selected (bug #356975)
(Portage version: 2.1.10.56/cvs/Linux x86_64)
-rw-r--r--sci-mathematics/fann/ChangeLog10
-rw-r--r--sci-mathematics/fann/fann-2.0.0.ebuild77
-rw-r--r--sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild10
-rw-r--r--sci-mathematics/fann/fann-2.1.0_beta.ebuild90
-rw-r--r--sci-mathematics/fann/fann-2.2.0.ebuild41
-rw-r--r--sci-mathematics/fann/files/fann-2.2.0-examples.patch23
6 files changed, 80 insertions, 171 deletions
diff --git a/sci-mathematics/fann/ChangeLog b/sci-mathematics/fann/ChangeLog
index 3f76ed17e71a..7f131356f48b 100644
--- a/sci-mathematics/fann/ChangeLog
+++ b/sci-mathematics/fann/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/fann
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.17 2012/02/25 03:24:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/ChangeLog,v 1.18 2012/05/08 18:18:55 bicatali Exp $
+
+*fann-2.2.0 (08 May 2012)
+
+ 08 May 2012; Sébastien Fabbro <bicatali@gentoo.org> -fann-2.0.0.ebuild,
+ -fann-2.1.0_beta.ebuild, fann-2.1.0_beta-r1.ebuild, +fann-2.2.0.ebuild,
+ +files/fann-2.2.0-examples.patch:
+ Version bump. Optimize python module only when python is selected (bug
+ #356975)
25 Feb 2012; Patrick Lauer <patrick@gentoo.org> fann-2.0.0.ebuild,
fann-2.1.0_beta-r1.ebuild, fann-2.1.0_beta.ebuild:
diff --git a/sci-mathematics/fann/fann-2.0.0.ebuild b/sci-mathematics/fann/fann-2.0.0.ebuild
deleted file mode 100644
index 64b89667f67e..000000000000
--- a/sci-mathematics/fann/fann-2.0.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.0.0.ebuild,v 1.8 2012/02/25 03:24:24 patrick Exp $
-
-EAPI=2
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils python
-
-MY_P=${P/_/}
-
-DESCRIPTION="Fast Artificial Neural Network Library"
-HOMEPAGE="http://leenissen.dk/fann/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc python"
-
-RDEPEND=""
-DEPEND="
- ${RDEPEND}
- python? ( dev-lang/swig )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-shared-libs-gentoo.patch \
- "${FILESDIR}"/${P}-benchmark.patch
- use python && python_copy_sources python
-}
-
-src_compile() {
- emake || die "failed to build src"
- compilation() {
- emake PYTHON_VERSION="$(python_get_version)" || die "emake python failed"
- }
- use python && python_execute_function -s --source-dir python compilation
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- if use doc; then
- dodoc doc/*.txt || \
- die "failed to install docs"
- insinto /usr/share/doc/${PF}
- doins doc/fann_en.pdf || \
- die "failed to install reference manual"
- insinto /usr/share/${PN}
- doins -r benchmarks || \
- die "failed to install benchmarks"
- doins -r examples || \
- die "failed to install examples"
- fi
-
- installation() {
- emake install ROOT="${D}" || die "failed to install python wrappers"
- if use doc; then
- insinto /usr/share/doc/${PF}/examples/python
- doins -r examples || die "failed to install python examples"
- fi
- }
- use python && python_execute_function -s --source-dir python installation
-}
-
-pkg_postinst() {
- python_mod_optimize py${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup py${PN}
-}
diff --git a/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild b/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
index 821fc11fe71e..d2c223ce8b2a 100644
--- a/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
+++ b/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild,v 1.2 2012/02/25 03:24:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild,v 1.3 2012/05/08 18:18:55 bicatali Exp $
EAPI=2
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/_beta/}"
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
src_prepare() {
epatch \
"${FILESDIR}"/${P}-python.patch \
@@ -87,9 +91,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize py${PN}
+ use python && python_mod_optimize py${PN}
}
pkg_postrm() {
- python_mod_cleanup py${PN}
+ use python && python_mod_cleanup py${PN}
}
diff --git a/sci-mathematics/fann/fann-2.1.0_beta.ebuild b/sci-mathematics/fann/fann-2.1.0_beta.ebuild
deleted file mode 100644
index feb39c9fcdac..000000000000
--- a/sci-mathematics/fann/fann-2.1.0_beta.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta.ebuild,v 1.6 2012/02/25 03:24:24 patrick Exp $
-
-EAPI=2
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils python autotools
-
-MY_P=${P/_/}
-
-DESCRIPTION="Fast Artificial Neural Network Library"
-HOMEPAGE="http://leenissen.dk/fann/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc python"
-
-RDEPEND=""
-DEPEND="
- ${RDEPEND}
- python? ( dev-lang/swig )
- app-arch/unzip"
-
-S="${WORKDIR}/${P/_beta/}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-python.patch \
- "${FILESDIR}"/${P}-benchmark.patch \
- "${FILESDIR}"/${P}-examples.patch \
- "${FILESDIR}"/${P}-asneeded.patch
- eautoreconf
- use python && python_copy_sources python
-}
-
-src_compile() {
- emake || die "emake failed"
- compilation() {
- emake PYTHON_VERSION="$(python_get_version)" || die "emake python failed"
- }
- use python && python_execute_function -s --source-dir python compilation
-}
-
-src_test() {
- cd "${S}"/examples
- emake CFLAGS="${CFLAGS} -I../src/include -L../src/.libs" \
- || die "emake examples failed"
- LD_LIBRARY_PATH="../src/.libs" emake runtest || die "tests failed"
- emake clean
- testing() {
- emake test || die "failed tests for python wrappers"
- }
- use python && python_execute_function -s --source-dir python testing
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
-
- if use doc; then
- dodoc doc/*.txt
- insinto /usr/share/doc/${PF}
- doins doc/fann_en.pdf || die "failed to install reference manual"
- doins -r examples || die "failed to install examples"
- doins -r benchmarks || die "failed to install benchmarks"
- fi
-
- installation() {
- emake install ROOT="${D}" || die "failed to install python wrappers"
- if use doc; then
- insinto /usr/share/doc/${PF}/examples/python
- doins -r examples || die "failed to install python examples"
- fi
- }
- use python && python_execute_function -s --source-dir python installation
-}
-
-pkg_postinst() {
- python_mod_optimize py${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup py${PN}
-}
diff --git a/sci-mathematics/fann/fann-2.2.0.ebuild b/sci-mathematics/fann/fann-2.2.0.ebuild
new file mode 100644
index 000000000000..35972a59eeb4
--- /dev/null
+++ b/sci-mathematics/fann/fann-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.2.0.ebuild,v 1.1 2012/05/08 18:18:55 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+MYP=FANN-${PV}-Source
+
+DESCRIPTION="Fast Artificial Neural Network Library"
+HOMEPAGE="http://leenissen.dk/fann/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${P}-examples.patch )
+
+src_test() {
+ cd examples
+ emake CFLAGS="${CFLAGS} -I../src/include -L${BUILD_DIR}/src"
+ LD_LIBRARY_PATH="${BUILD_DIR}/src" emake runtest
+ emake clean
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-mathematics/fann/files/fann-2.2.0-examples.patch b/sci-mathematics/fann/files/fann-2.2.0-examples.patch
new file mode 100644
index 000000000000..bfab17022187
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-2.2.0-examples.patch
@@ -0,0 +1,23 @@
+--- examples/Makefile.orig 2012-01-24 05:31:40.000000000 +0000
++++ examples/Makefile 2012-05-08 19:00:08.000000000 +0100
+@@ -1,7 +1,6 @@
+ # This makefile is on purpose not made with configure, to show how to use the library
+ # The make file requires that the fann library is installed (see ../README)
+
+-GCC=gcc
+
+ TARGETS = xor_train xor_test xor_test_fixed simple_train steepness_train simple_test robot mushroom cascade_train scaling_test scaling_train
+ DEBUG_TARGETS = xor_train_debug xor_test_debug xor_test_fixed_debug cascade_train_debug
+@@ -9,10 +8,10 @@
+ all: $(TARGETS)
+
+ %: %.c Makefile
+- $(GCC) -O3 $< -o $@ -lfann -lm
++ $(CC) $(CFLAGS) $< -lfann -lm -o $@
+
+ %_fixed: %.c Makefile
+- $(GCC) -O3 -DFIXEDFANN $< -o $@ -lfixedfann -lm
++ $(CC) $(CFLAGS) -DFIXEDFANN $< -lfixedfann -lm -o $@
+
+ clean:
+ rm -f $(TARGETS) $(DEBUG_TARGETS) xor_fixed.data *.net *~ *.obj *.exe *.tds noscale.txt withscale.txt scale_test_results.txt