summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild')
-rw-r--r--sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild b/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
index 821fc11fe71e..d2c223ce8b2a 100644
--- a/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
+++ b/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild,v 1.2 2012/02/25 03:24:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/fann/fann-2.1.0_beta-r1.ebuild,v 1.3 2012/05/08 18:18:55 bicatali Exp $
EAPI=2
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/_beta/}"
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
src_prepare() {
epatch \
"${FILESDIR}"/${P}-python.patch \
@@ -87,9 +91,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize py${PN}
+ use python && python_mod_optimize py${PN}
}
pkg_postrm() {
- python_mod_cleanup py${PN}
+ use python && python_mod_cleanup py${PN}
}