summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-06 16:14:10 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-06 16:14:10 +0000
commitacbd5ac8f2ef18e6bb6d772417c2688b4f9a0e9e (patch)
tree606030b1943f3c9327f768e88d6975c57561fa9e /sci-chemistry
parentmedia-gfx/tachyon: Defaulting on USE=opengl, #422815; adding virtual/glu to d... (diff)
downloadgentoo-2-acbd5ac8f2ef18e6bb6d772417c2688b4f9a0e9e.tar.gz
gentoo-2-acbd5ac8f2ef18e6bb6d772417c2688b4f9a0e9e.tar.bz2
gentoo-2-acbd5ac8f2ef18e6bb6d772417c2688b4f9a0e9e.zip
sci-chemistry/openbabel: Version Bump prepared by Reinis Danne, #439434
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/ChangeLog8
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch27
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.2.ebuild80
3 files changed, 114 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
index f4b2faa6ffb3..34238943e1d8 100644
--- a/sci-chemistry/openbabel/ChangeLog
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.59 2012/04/26 15:46:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.60 2012/12/06 16:14:10 jlec Exp $
+
+*openbabel-2.3.2 (06 Dec 2012)
+
+ 06 Dec 2012; Justin Lecher <jlec@gentoo.org> +openbabel-2.3.2.ebuild,
+ +files/openbabel-2.3.2-test_lib_path.patch:
+ Version Bump prepared by Reinis Danne, #439434
26 Apr 2012; Justin Lecher <jlec@gentoo.org> openbabel-2.2.3.ebuild:
Drop unnessecary die
diff --git a/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch b/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch
new file mode 100644
index 000000000000..1354f52685c6
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch
@@ -0,0 +1,27 @@
+diff -ru old/openbabel-2.3.0/test/CMakeLists.txt new/openbabel-2.3.0/test/CMakeLists.txt
+--- old/openbabel-2.3.0/test/CMakeLists.txt 2010-10-26 17:39:01.000000000 +0300
++++ new/openbabel-2.3.0/test/CMakeLists.txt 2010-11-14 18:13:32.000000000 +0200
+@@ -2,7 +2,7 @@
+ add_definitions(-DTESTDATADIR="\\"${CMAKE_SOURCE_DIR}/test/files/\\"")
+
+ # define FORMATDIR for location of format plugin binaries
+-add_definitions(-DFORMATDIR="\\"${openbabel_BINARY_DIR}/lib/\\"")
++add_definitions(-DFORMATDIR="\\"${openbabel_BINARY_DIR}/lib${LIB_SUFFIX}/\\"")
+
+ ###########################################################
+ # new tests using obtest.h
+@@ -32,12 +35,12 @@ set(tests
+ uniqueid
+ )
+
+-if (EIGEN2_FOUND)
++if(EIGEN2_FOUND OR EIGEN3_FOUND)
+ set(tests
+ align
+ ${tests}
+ )
+-endif (EIGEN2_FOUND)
++endif()
+
+ set(TEST_PATH ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+
diff --git a/sci-chemistry/openbabel/openbabel-2.3.2.ebuild b/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
new file mode 100644
index 000000000000..924e7a54c935
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-2.3.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.3.2.ebuild,v 1.1 2012/12/06 16:14:10 jlec Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit cmake-utils eutils wxwidgets
+
+DESCRIPTION="Interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp perl python test wxwidgets"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/libxml2:2
+ !sci-chemistry/babel
+ sci-libs/inchi
+ sys-libs/zlib
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8
+ doc? ( app-doc/doxygen )"
+PDEPEND="
+ perl? ( sci-chemistry/openbabel-perl )
+ python? ( sci-chemistry/openbabel-python )"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
+
+PATCHES=( "${FILESDIR}"/${P}-test_lib_path.patch )
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use_enable openmp OPENMP)
+ $(cmake-utils_use wxwidgets BUILD_GUI)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dohtml doc/{*.html,*.png}
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/API/html
+ doins doc/API/html/*
+ fi
+
+ cmake-utils_src_install
+}
+
+src_test() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DPYTHON_EXECUTABLE=false
+ $(cmake-utils_use_enable openmp OPENMP)
+ $(cmake-utils_use wxwidgets BUILD_GUI)
+ $(cmake-utils_use_enable test TESTS)"
+
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test -E py
+}