summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-07 16:40:39 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-07 16:40:39 +0000
commit56e6cb9b79fb70c5a4046c3ba7f1fcd568c414e9 (patch)
tree2fa53164a8bfbbc8cf9bc5f3fcef2efad6fcc7a5 /sci-chemistry
parentFix compilation on platforms where /bin/sh is bourne, but not POSIX shell (e.... (diff)
downloadgentoo-2-56e6cb9b79fb70c5a4046c3ba7f1fcd568c414e9.tar.gz
gentoo-2-56e6cb9b79fb70c5a4046c3ba7f1fcd568c414e9.tar.bz2
gentoo-2-56e6cb9b79fb70c5a4046c3ba7f1fcd568c414e9.zip
Version Bump
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molrep/ChangeLog7
-rw-r--r--sci-chemistry/molrep/molrep-11.0.03.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-chemistry/molrep/ChangeLog b/sci-chemistry/molrep/ChangeLog
index 6edd0f6248f4..59cc4096e09b 100644
--- a/sci-chemistry/molrep/ChangeLog
+++ b/sci-chemistry/molrep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/molrep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.18 2011/07/02 08:55:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.19 2011/09/07 16:40:39 jlec Exp $
+
+*molrep-11.0.03 (07 Sep 2011)
+
+ 07 Sep 2011; Justin Lecher <jlec@gentoo.org> +molrep-11.0.03.ebuild:
+ Version Bump
02 Jul 2011; Justin Lecher <jlec@gentoo.org> molrep-11.0.02.ebuild,
metadata.xml:
diff --git a/sci-chemistry/molrep/molrep-11.0.03.ebuild b/sci-chemistry/molrep/molrep-11.0.03.ebuild
new file mode 100644
index 000000000000..d01988129d41
--- /dev/null
+++ b/sci-chemistry/molrep/molrep-11.0.03.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-11.0.03.ebuild,v 1.1 2011/09/07 16:40:38 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="molecular replacement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/molrep.html"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ virtual/fortran
+
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/mmdb
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/11.0.00-respect-FLAGS.patch \
+ "${FILESDIR}"/11.0.00-test.patch
+ [[ $(tc-getFC) =~ gfortran ]] && append-fflags -fno-second-underscore
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake clean
+ emake \
+ MR_FORT="$(tc-getFC) ${FFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c $(pkg-config --libs mmdb lapack) -lccif -lstdc++ -lm"
+}
+
+src_test() {
+ export MR_TEST="${S}/bin/"
+ cd "${S}"/molrep_check/work
+ mkdir out scr
+ cp ../*.bat .
+ bash em.bat || die
+ bash mr.bat || die
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe bin/${PN}
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc readme doc/${PN}.rtf
+}