summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-14 20:15:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-14 20:15:22 +0000
commit9334f80c53fd314b23c985c834ebc90792dbfd4e (patch)
tree3e4c99170588a52e262ecc40a9c2c98ed54e3c57 /sci-chemistry/suitename
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-9334f80c53fd314b23c985c834ebc90792dbfd4e.tar.gz
gentoo-2-9334f80c53fd314b23c985c834ebc90792dbfd4e.tar.bz2
gentoo-2-9334f80c53fd314b23c985c834ebc90792dbfd4e.zip
New addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/suitename')
-rw-r--r--sci-chemistry/suitename/ChangeLog10
-rw-r--r--sci-chemistry/suitename/metadata.xml22
-rw-r--r--sci-chemistry/suitename/suitename-0.3.070628.ebuild37
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-chemistry/suitename/ChangeLog b/sci-chemistry/suitename/ChangeLog
new file mode 100644
index 000000000000..c54690c7d9c4
--- /dev/null
+++ b/sci-chemistry/suitename/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/suitename
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/suitename/ChangeLog,v 1.1 2010/07/14 20:15:22 jlec Exp $
+
+*suitename-0.3.070628 (14 Jul 2010)
+
+ 14 Jul 2010; Justin Lecher <jlec@gentoo.org> +suitename-0.3.070628.ebuild,
+ +metadata.xml:
+ New addition
+
diff --git a/sci-chemistry/suitename/metadata.xml b/sci-chemistry/suitename/metadata.xml
new file mode 100644
index 000000000000..37e91c3ef75f
--- /dev/null
+++ b/sci-chemistry/suitename/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+Suitename is a new C program that supports the ROC RNA Ontology Consortium
+consensus RNA backbone nomenclature and conformer-list development (see our RNA
+backbone rotamer section.
+From dihedral-angle input for a specific RNA structure (usually from Dangle),
+Suitename categorizes the RNA backbone geometry of each suite (the
+sugar-to-sugar version of a residue) either as an outlier ("!!") or as belonging
+to one of the 53 defined conformer bins. The output is either a
+one-line-per-suite report, or a linear conformer string (as shown below the
+image here) in one of several variant formats. Suitename is built into
+MolProbity, producing entries in the multi-criterion chart for an RNA model and
+also a suitestring file. The Suitename code is made available here for bulk or
+individual command-line use.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/suitename/suitename-0.3.070628.ebuild b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
new file mode 100644
index 000000000000..21ceea4a7006
--- /dev/null
+++ b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/suitename/suitename-0.3.070628.ebuild,v 1.1 2010/07/14 20:15:22 jlec Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Program that supports the ROC RNA Ontology Consortium consensus RNA backbone nomenclature and conformer-list development"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="richardson"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ tc-export CC
+ cp Makefile.linux Makefile || die
+ sed \
+ -e "s:-o:${LDFLAGS} -o:g" \
+ -e 's:cc:${CC}:g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin ${PN} || die
+}