summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 20:48:56 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 20:48:56 +0000
commit5c49999bdbadbef0486d4cc626db73c71609836f (patch)
tree044026ef15f5161ee41030daa46830938ff05e1d /sci-biology
parentstable for amd64 wrt bug #422473 (diff)
downloadgentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.tar.gz
gentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.tar.bz2
gentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.zip
sci-biology/abyss: Fix compilation with gcc-4.7, #422599; install docs inside /usr/share/doc/, #297205
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/abyss/ChangeLog10
-rw-r--r--sci-biology/abyss/abyss-1.3.0.ebuild5
-rw-r--r--sci-biology/abyss/abyss-1.3.3.ebuild6
-rw-r--r--sci-biology/abyss/abyss-1.3.4.ebuild37
-rw-r--r--sci-biology/abyss/files/abyss-1.3.3-gcc-4.7.patch15
-rw-r--r--sci-biology/abyss/files/abyss-1.3.4-gcc-4.7.patch15
6 files changed, 83 insertions, 5 deletions
diff --git a/sci-biology/abyss/ChangeLog b/sci-biology/abyss/ChangeLog
index 7d16878ef343..2264b549eeea 100644
--- a/sci-biology/abyss/ChangeLog
+++ b/sci-biology/abyss/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/abyss
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.12 2012/05/29 02:44:21 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.13 2012/06/20 20:48:56 jlec Exp $
+
+*abyss-1.3.4 (20 Jun 2012)
+
+ 20 Jun 2012; Justin Lecher <jlec@gentoo.org> abyss-1.3.0.ebuild,
+ abyss-1.3.3.ebuild, +files/abyss-1.3.3-gcc-4.7.patch, +abyss-1.3.4.ebuild,
+ +files/abyss-1.3.4-gcc-4.7.patch:
+ Fix compilation with gcc-4.7, #422599; install docs inside /usr/share/doc/,
+ #297205
*abyss-1.3.3 (29 May 2012)
diff --git a/sci-biology/abyss/abyss-1.3.0.ebuild b/sci-biology/abyss/abyss-1.3.0.ebuild
index dbb174c71163..4ac14a4e2c49 100644
--- a/sci-biology/abyss/abyss-1.3.0.ebuild
+++ b/sci-biology/abyss/abyss-1.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.0.ebuild,v 1.1 2011/09/24 21:48:12 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.0.ebuild,v 1.2 2012/06/20 20:48:56 jlec Exp $
EAPI="4"
@@ -31,5 +31,6 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable openmp)
}
diff --git a/sci-biology/abyss/abyss-1.3.3.ebuild b/sci-biology/abyss/abyss-1.3.3.ebuild
index edc248a34395..5c372876b248 100644
--- a/sci-biology/abyss/abyss-1.3.3.ebuild
+++ b/sci-biology/abyss/abyss-1.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.1 2012/05/29 02:44:21 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.2 2012/06/20 20:48:56 jlec Exp $
EAPI="4"
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
@@ -24,6 +24,7 @@ RDEPEND="${DEPEND}"
# todo: fix automagic mpi toggling
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
sed -i -e "s/-Werror//" configure.ac || die #365195
sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
eautoreconf
@@ -31,5 +32,6 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable openmp)
}
diff --git a/sci-biology/abyss/abyss-1.3.4.ebuild b/sci-biology/abyss/abyss-1.3.4.ebuild
new file mode 100644
index 000000000000..6ce67798ca99
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.4.ebuild,v 1.1 2012/06/20 20:48:56 jlec Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-cpp/sparsehash
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable openmp)
+}
diff --git a/sci-biology/abyss/files/abyss-1.3.3-gcc-4.7.patch b/sci-biology/abyss/files/abyss-1.3.3-gcc-4.7.patch
new file mode 100644
index 000000000000..42066f7f2152
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.3-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ ParseAligns/abyss-fixmate.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/ParseAligns/abyss-fixmate.cc b/ParseAligns/abyss-fixmate.cc
+index 506ea0c..a0a403c 100644
+--- a/ParseAligns/abyss-fixmate.cc
++++ b/ParseAligns/abyss-fixmate.cc
+@@ -15,6 +15,7 @@
+ #include <iterator>
+ #include <sstream>
+ #include <string>
++#include <unistd.h>
+
+ using namespace std;
+
diff --git a/sci-biology/abyss/files/abyss-1.3.4-gcc-4.7.patch b/sci-biology/abyss/files/abyss-1.3.4-gcc-4.7.patch
new file mode 100644
index 000000000000..c2cc35c31d98
--- /dev/null
+++ b/sci-biology/abyss/files/abyss-1.3.4-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ ParseAligns/abyss-fixmate.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/ParseAligns/abyss-fixmate.cc b/ParseAligns/abyss-fixmate.cc
+index 1a169cf..36cc05b 100644
+--- a/ParseAligns/abyss-fixmate.cc
++++ b/ParseAligns/abyss-fixmate.cc
+@@ -16,6 +16,7 @@
+ #include <iterator>
+ #include <sstream>
+ #include <string>
++#include <unistd.h>
+
+ using namespace std;
+