summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/abyss/abyss-1.3.3.ebuild')
-rw-r--r--sci-biology/abyss/abyss-1.3.3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-biology/abyss/abyss-1.3.3.ebuild b/sci-biology/abyss/abyss-1.3.3.ebuild
index edc248a34395..5c372876b248 100644
--- a/sci-biology/abyss/abyss-1.3.3.ebuild
+++ b/sci-biology/abyss/abyss-1.3.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.1 2012/05/29 02:44:21 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.2 2012/06/20 20:48:56 jlec Exp $
EAPI="4"
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
@@ -24,6 +24,7 @@ RDEPEND="${DEPEND}"
# todo: fix automagic mpi toggling
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
sed -i -e "s/-Werror//" configure.ac || die #365195
sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
eautoreconf
@@ -31,5 +32,6 @@ src_prepare() {
src_configure() {
econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable openmp)
}