summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-23 16:54:03 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-23 16:54:03 +0000
commitd77c0aeec30ad9ba93d00348fef4a2aa582ec959 (patch)
treee8bec24ba109702bd212b4fefb925063d529c732 /sci-biology/prosite
parentFix #83048. (diff)
downloadgentoo-2-d77c0aeec30ad9ba93d00348fef4a2aa582ec959.tar.gz
gentoo-2-d77c0aeec30ad9ba93d00348fef4a2aa582ec959.tar.bz2
gentoo-2-d77c0aeec30ad9ba93d00348fef4a2aa582ec959.zip
Added support for the "emboss" and "minimal" "USE" flags. Added 18.44 to x86.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-biology/prosite')
-rw-r--r--sci-biology/prosite/ChangeLog8
-rw-r--r--sci-biology/prosite/prosite-18.38.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.39.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.40.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.41.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.42.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.43.ebuild18
-rw-r--r--sci-biology/prosite/prosite-18.44.ebuild4
8 files changed, 67 insertions, 53 deletions
diff --git a/sci-biology/prosite/ChangeLog b/sci-biology/prosite/ChangeLog
index 6690ffe3d497..4a289714ba0b 100644
--- a/sci-biology/prosite/ChangeLog
+++ b/sci-biology/prosite/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for sci-biology/prosite
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/ChangeLog,v 1.9 2005/02/23 04:09:28 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/ChangeLog,v 1.10 2005/02/23 16:54:03 ribosome Exp $
- 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> prosite-18.44.ebuild:
- Added support for the "emboss" and "minimal" "USE" flags.
+ 23 Feb 2005; Olivier Fisette <ribosome@gentoo.org> prosite-18.38.ebuild,
+ prosite-18.39.ebuild, prosite-18.40.ebuild, prosite-18.41.ebuild,
+ prosite-18.42.ebuild, prosite-18.43.ebuild, prosite-18.44.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags. Added 18.44 to x86.
18 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org> prosite-18.43.ebuild:
Stable ppc-macos
diff --git a/sci-biology/prosite/prosite-18.38.ebuild b/sci-biology/prosite/prosite-18.38.ebuild
index 795dc1f5e2ba..34fc69ae88a4 100644
--- a/sci-biology/prosite/prosite-18.38.ebuild
+++ b/sci-biology/prosite/prosite-18.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.38.ebuild,v 1.3 2005/01/02 15:17:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.38.ebuild,v 1.4 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.39.ebuild b/sci-biology/prosite/prosite-18.39.ebuild
index 632a882914ea..8f43662c81dc 100644
--- a/sci-biology/prosite/prosite-18.39.ebuild
+++ b/sci-biology/prosite/prosite-18.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.39.ebuild,v 1.3 2005/01/02 15:17:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.39.ebuild,v 1.4 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.40.ebuild b/sci-biology/prosite/prosite-18.40.ebuild
index 2ca7e7637e1d..a7bd5c5b92f4 100644
--- a/sci-biology/prosite/prosite-18.40.ebuild
+++ b/sci-biology/prosite/prosite-18.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.40.ebuild,v 1.3 2005/01/02 15:17:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.40.ebuild,v 1.4 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.41.ebuild b/sci-biology/prosite/prosite-18.41.ebuild
index 8b6818177e0a..efc2ce504437 100644
--- a/sci-biology/prosite/prosite-18.41.ebuild
+++ b/sci-biology/prosite/prosite-18.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.41.ebuild,v 1.4 2005/01/02 15:17:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.41.ebuild,v 1.5 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.42.ebuild b/sci-biology/prosite/prosite-18.42.ebuild
index 087b1001962a..ee622ab86890 100644
--- a/sci-biology/prosite/prosite-18.42.ebuild
+++ b/sci-biology/prosite/prosite-18.42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.42.ebuild,v 1.5 2005/02/02 21:34:41 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.42.ebuild,v 1.6 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.43.ebuild b/sci-biology/prosite/prosite-18.43.ebuild
index 75a022654d04..c7b8b88b2bd0 100644
--- a/sci-biology/prosite/prosite-18.43.ebuild
+++ b/sci-biology/prosite/prosite-18.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.43.ebuild,v 1.3 2005/02/19 04:31:09 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.43.ebuild,v 1.4 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi
diff --git a/sci-biology/prosite/prosite-18.44.ebuild b/sci-biology/prosite/prosite-18.44.ebuild
index 77b87c96f8c2..1d25cde77188 100644
--- a/sci-biology/prosite/prosite-18.44.ebuild
+++ b/sci-biology/prosite/prosite-18.44.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.44.ebuild,v 1.2 2005/02/23 04:09:28 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.44.ebuild,v 1.3 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~ppc-macos"
+KEYWORDS="x86 ~ppc ~ppc-macos"
IUSE="emboss minimal"
# Minimal build keeps only the indexed files (if applicable) and the documentation.
# The non-indexed database is not installed.