summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/prosite/prosite-18.40.ebuild')
-rw-r--r--sci-biology/prosite/prosite-18.40.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-biology/prosite/prosite-18.40.ebuild b/sci-biology/prosite/prosite-18.40.ebuild
index 2ca7e7637e1d..a7bd5c5b92f4 100644
--- a/sci-biology/prosite/prosite-18.40.ebuild
+++ b/sci-biology/prosite/prosite-18.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.40.ebuild,v 1.3 2005/01/02 15:17:32 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-18.40.ebuild,v 1.4 2005/02/23 16:54:03 ribosome Exp $
DESCRIPTION="A protein families and domains database"
HOMEPAGE="http://ca.expasy.org/prosite"
@@ -8,27 +8,29 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="swiss-prot"
SLOT="0"
KEYWORDS="x86 ~ppc"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with EMBOSS if EMBOSS is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PROSITE
+ echo
einfo "Indexing PROSITE for usage with EMBOSS."
- EMBOSS_DATA=. prosextract -auto -infdat ${S} || die \
+ EMBOSS_DATA="." prosextract -auto -infdat ${S} || die \
"Indexing PROSITE failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}.{doc,dat,lis}
fi
dodoc *.txt
dohtml prosuser.htm
- if [ -e /usr/bin/prosextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PROSITE
doins PROSITE/*
fi