summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-11-22 13:26:59 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-11-22 13:26:59 +0000
commitb4d2d4d5a962923261b9d66260b8af2d8f329ea8 (patch)
tree2e8de77caea9a61ea6a4db29dc11be2b19311623 /sci-biology/paml
parentamd64 stable wrt #199979 (diff)
downloadgentoo-2-b4d2d4d5a962923261b9d66260b8af2d8f329ea8.tar.gz
gentoo-2-b4d2d4d5a962923261b9d66260b8af2d8f329ea8.tar.bz2
gentoo-2-b4d2d4d5a962923261b9d66260b8af2d8f329ea8.zip
Version bump. See bug #191867.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-biology/paml')
-rw-r--r--sci-biology/paml/ChangeLog9
-rw-r--r--sci-biology/paml/files/digest-paml-4a3
-rw-r--r--sci-biology/paml/paml-3.15.ebuild4
-rw-r--r--sci-biology/paml/paml-4a.ebuild40
4 files changed, 52 insertions, 4 deletions
diff --git a/sci-biology/paml/ChangeLog b/sci-biology/paml/ChangeLog
index 94cfb9154e51..c2a2b9967f02 100644
--- a/sci-biology/paml/ChangeLog
+++ b/sci-biology/paml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/paml
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.1 2006/10/21 05:57:50 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.2 2007/11/22 13:26:59 markusle Exp $
+
+*paml-4a (22 Nov 2007)
+
+ 22 Nov 2007; Markus Dittrich <markusle@gentoo.org> +paml-4a.ebuild:
+ Version bump. See bug #191867.
*paml-3.15 (21 Oct 2006)
diff --git a/sci-biology/paml/files/digest-paml-4a b/sci-biology/paml/files/digest-paml-4a
new file mode 100644
index 000000000000..dd55c75cab35
--- /dev/null
+++ b/sci-biology/paml/files/digest-paml-4a
@@ -0,0 +1,3 @@
+MD5 3cbe2e2ef633398e66443d08ccf16322 paml4a.tar.gz 2377543
+RMD160 5be2b6e82f0abc52e1e4251a0b8728e4cece684b paml4a.tar.gz 2377543
+SHA256 436968adfad51c0b9f28a5bc1196a5e123005b8e9c6df0c4200d791b7ed90f4e paml4a.tar.gz 2377543
diff --git a/sci-biology/paml/paml-3.15.ebuild b/sci-biology/paml/paml-3.15.ebuild
index 7e2fa5e5d513..4c5ab262db60 100644
--- a/sci-biology/paml/paml-3.15.ebuild
+++ b/sci-biology/paml/paml-3.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-3.15.ebuild,v 1.1 2006/10/21 05:57:50 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-3.15.ebuild,v 1.2 2007/11/22 13:26:59 markusle Exp $
inherit toolchain-funcs
diff --git a/sci-biology/paml/paml-4a.ebuild b/sci-biology/paml/paml-4a.ebuild
new file mode 100644
index 000000000000..ded1fad3745c
--- /dev/null
+++ b/sci-biology/paml/paml-4a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4a.ebuild,v 1.1 2007/11/22 13:26:59 markusle Exp $
+
+inherit toolchain-funcs
+
+MY_PV="${PV:0:1}"
+MY_P="${PN}${MY_PV}"
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${PN}${PV}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd src
+ emake \
+ -f Makefile.UNIX \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ pushd "${S}"/src
+ dobin baseml codeml basemlg mcmctree pamp evolver yn00 chi2
+ popd
+ dodoc README.txt doc/*
+ insinto /usr/share/${PN}/control
+ doins *.ctl || die "Failed to install control files"
+ insinto /usr/share/${PN}/dat
+ doins stewart* *.dat dat/* || die "Failed to install data files"
+ insinto /usr/share/${PN}
+ doins -r examples/ || die "Failed to install examples"
+}