summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2012-02-27 16:06:59 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2012-02-27 16:06:59 +0000
commitfa77429e90dc9440dd61ce3a9ce36e46fe4d2afa (patch)
tree92d6bc925b5a6b740a78b31cbea85ba833968d5f /sci-biology/biopython
parentMarking matplotlib-1.1.0 ppc for bug 403847 (diff)
downloadgentoo-2-fa77429e90dc9440dd61ce3a9ce36e46fe4d2afa.tar.gz
gentoo-2-fa77429e90dc9440dd61ce3a9ce36e46fe4d2afa.tar.bz2
gentoo-2-fa77429e90dc9440dd61ce3a9ce36e46fe4d2afa.zip
Version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/ChangeLog9
-rw-r--r--sci-biology/biopython/biopython-1.59.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index d8ebb4cc0485..2a44ae7bff76 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/biopython
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.66 2011/12/26 05:51:16 weaver Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.67 2012/02/27 16:06:58 weaver Exp $
+
+*biopython-1.59 (27 Feb 2012)
+
+ 27 Feb 2012; Andrey Kislyuk <weaver@gentoo.org> +biopython-1.59.ebuild:
+ Version bump
26 Dec 2011; Andrey Kislyuk <weaver@gentoo.org> +biopython-1.58.ebuild:
Version bump
diff --git a/sci-biology/biopython/biopython-1.59.ebuild b/sci-biology/biopython/biopython-1.59.ebuild
new file mode 100644
index 000000000000..1a4a7397c2ff
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.59.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.59.ebuild,v 1.1 2012/02/27 16:06:59 weaver Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="
+ dev-python/numpy
+ dev-python/reportlab
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="CONTRIB DEPRECATED NEWS README"
+PYTHON_MODNAME="Bio BioSQL"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-1.51-flex.patch"
+}
+
+src_test() {
+ testing() {
+ cd Tests
+ PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
+ }
+ python_execute_function --nonfatal -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r Doc/* || die "Installation of documentation failed"
+ insinto /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}usr/share/${PN}" || die "Installation of shared files failed"
+}