summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-22 22:35:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-22 22:35:53 +0000
commitd48f21a8af0a0a9f66607cbd08d59d64b8be749a (patch)
treea14d61cb5b1c75c56632ac69a272e1b63158db00 /net-nds/portmap
parentversion bump (diff)
downloadgentoo-2-d48f21a8af0a0a9f66607cbd08d59d64b8be749a.tar.gz
gentoo-2-d48f21a8af0a0a9f66607cbd08d59d64b8be749a.tar.bz2
gentoo-2-d48f21a8af0a0a9f66607cbd08d59d64b8be749a.zip
Add patch to delete the $(SYS) variable which isnt used at all #83000 by Mihai Limbasan.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-nds/portmap')
-rw-r--r--net-nds/portmap/ChangeLog7
-rw-r--r--net-nds/portmap/files/portmap-5b-no-SYS.patch16
-rw-r--r--net-nds/portmap/portmap-5b-r9.ebuild23
3 files changed, 35 insertions, 11 deletions
diff --git a/net-nds/portmap/ChangeLog b/net-nds/portmap/ChangeLog
index b500dd03f239..9a280663fcb2 100644
--- a/net-nds/portmap/ChangeLog
+++ b/net-nds/portmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/portmap
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/ChangeLog,v 1.30 2005/02/07 19:46:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/ChangeLog,v 1.31 2005/02/22 22:35:52 vapier Exp $
+
+ 22 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/portmap-5b-no-SYS.patch, portmap-5b-r9.ebuild:
+ Add patch to delete the $(SYS) variable which isnt used at all #83000 by
+ Mihai Limbasan.
07 Feb 2005; Markus Rothe <corsair@gentoo.org> -portmap-5b-r8.ebuild,
portmap-5b-r9.ebuild:
diff --git a/net-nds/portmap/files/portmap-5b-no-SYS.patch b/net-nds/portmap/files/portmap-5b-no-SYS.patch
new file mode 100644
index 000000000000..ca8798d21b91
--- /dev/null
+++ b/net-nds/portmap/files/portmap-5b-no-SYS.patch
@@ -0,0 +1,16 @@
+The Makefile doesn't actually use the SYS variable and having it
+set in your env can cause weird build failures. Just punt it.
+
+http://bugs.gentoo.org/show_bug.cgi?id=83000
+
+--- portmap/Makefile
++++ portmap/Makefile
+@@ -109,7 +109,7 @@
+ SHELL = /bin/sh
+
+ COPT = $(CONST) -Dperror=xperror $(CHECK_PORT) \
+- $(SYS) -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(SA_LEN) \
++ -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(SA_LEN) \
+ $(LOOPBACK) $(SETPGRP)
+ CFLAGS = $(COPT) $(O) $(NSARCHS)
+ OBJECTS = portmap.o pmap_check.o from_local.o $(AUX)
diff --git a/net-nds/portmap/portmap-5b-r9.ebuild b/net-nds/portmap/portmap-5b-r9.ebuild
index 15e77f70182b..c7144b2f59f1 100644
--- a/net-nds/portmap/portmap-5b-r9.ebuild
+++ b/net-nds/portmap/portmap-5b-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/portmap-5b-r9.ebuild,v 1.12 2005/02/07 19:46:40 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/portmap/portmap-5b-r9.ebuild,v 1.13 2005/02/22 22:35:53 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -27,25 +27,28 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}_5beta.dif
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}_5beta.dif
# Redhat patches
- epatch ${FILESDIR}/${PN}-4.0-malloc.patch
- epatch ${FILESDIR}/${PN}-4.0-cleanup.patch
- epatch ${FILESDIR}/${PN}-4.0-rpc_user.patch
- epatch ${FILESDIR}/${PN}-4.0-sigpipe.patch
+ epatch "${FILESDIR}"/${PN}-4.0-malloc.patch
+ epatch "${FILESDIR}"/${PN}-4.0-cleanup.patch
+ epatch "${FILESDIR}"/${PN}-4.0-rpc_user.patch
+ epatch "${FILESDIR}"/${PN}-4.0-sigpipe.patch
# Should include errno.h, and not define as external. Fix
# relocation error and build problem with glibc-2.3.2 cvs ...
# <azarah@gentoo.org> (31 Dec 2002).
- epatch ${FILESDIR}/${P}-include-errno_h.patch
+ epatch "${FILESDIR}"/${P}-include-errno_h.patch
# Patch to listen on loopback only #65199
- epatch ${FILESDIR}/${P}-loopback-only.patch
+ epatch "${FILESDIR}"/${P}-loopback-only.patch
# Make tcp wrapper checks easier
- epatch ${FILESDIR}/${P}-optional-tcpd.patch
+ epatch "${FILESDIR}"/${P}-optional-tcpd.patch
+
+ # Remove useless make variable #83000
+ epatch "${FILESDIR}"/${P}-no-SYS.patch
}
src_compile() {