summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/portmap/files/portmap-5b-no-SYS.patch')
-rw-r--r--net-nds/portmap/files/portmap-5b-no-SYS.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/net-nds/portmap/files/portmap-5b-no-SYS.patch b/net-nds/portmap/files/portmap-5b-no-SYS.patch
new file mode 100644
index 000000000000..ca8798d21b91
--- /dev/null
+++ b/net-nds/portmap/files/portmap-5b-no-SYS.patch
@@ -0,0 +1,16 @@
+The Makefile doesn't actually use the SYS variable and having it
+set in your env can cause weird build failures. Just punt it.
+
+http://bugs.gentoo.org/show_bug.cgi?id=83000
+
+--- portmap/Makefile
++++ portmap/Makefile
+@@ -109,7 +109,7 @@
+ SHELL = /bin/sh
+
+ COPT = $(CONST) -Dperror=xperror $(CHECK_PORT) \
+- $(SYS) -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(SA_LEN) \
++ -DFACILITY=$(FACILITY) $(ULONG) $(ZOMBIES) $(SA_LEN) \
+ $(LOOPBACK) $(SETPGRP)
+ CFLAGS = $(COPT) $(O) $(NSARCHS)
+ OBJECTS = portmap.o pmap_check.o from_local.o $(AUX)