summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 14:24:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 14:24:39 +0000
commitcf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f (patch)
treeaa9eb22ed0f873a9796957a12b3b575f30fdf213 /net-misc/netpipe
parentold (Manifest recommit) (diff)
downloadgentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.tar.gz
gentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.tar.bz2
gentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.zip
use $(tc-getCC)
Diffstat (limited to 'net-misc/netpipe')
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
index 01406492d9ab..c0deb037b4ec 100644
--- a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
@@ -1,35 +1,34 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild,v 1.6 2004/09/03 14:00:54 dholm Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild,v 1.7 2004/10/26 14:24:39 vapier Exp $
DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
-
-SRC_URI="http://home.t-online.de/home/gerd.o/netpipe.tar.gz"
HOMEPAGE="http://home.t-online.de/home/gerd.o/netpipe.html"
+SRC_URI="http://home.t-online.de/home/gerd.o/netpipe.tar.gz"
-DEPEND="virtual/libc"
-
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc"
S="${WORKDIR}/netpipe"
src_unpack() {
- unpack ${A} ; cd ${S}
- mv Makefile Makefile.orig
- sed -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
- -e "s:^#CC.*:CC = gcc:" \
- Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
+ -e "s:^#CC.*:CC = $(tc-getCC):" \
+ Makefile
}
src_compile() {
make || die
}
-src_install () {
- dobin netpipe
+src_install() {
+ dobin netpipe || die
dodoc DOCUMENTATION INSTALL TECH-NOTES
}