summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 14:24:39 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 14:24:39 +0000
commitcf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f (patch)
treeaa9eb22ed0f873a9796957a12b3b575f30fdf213 /net-misc
parentold (Manifest recommit) (diff)
downloadgentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.tar.gz
gentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.tar.bz2
gentoo-2-cf6c78153f06bbb5e1fb31c6db24ed5c7fb3b39f.zip
use $(tc-getCC)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/freenet6/freenet6-1.0.0.ebuild17
-rw-r--r--net-misc/host/host-991529.ebuild30
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2.ebuild31
3 files changed, 42 insertions, 36 deletions
diff --git a/net-misc/freenet6/freenet6-1.0.0.ebuild b/net-misc/freenet6/freenet6-1.0.0.ebuild
index bb9e1ec65ac2..65a75b1a5a8d 100644
--- a/net-misc/freenet6/freenet6-1.0.0.ebuild
+++ b/net-misc/freenet6/freenet6-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.5 2004/07/15 02:49:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.6 2004/10/26 14:20:29 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
HOMEPAGE="http://www.freenet6.net/"
@@ -8,18 +10,19 @@ SRC_URI="mirror://gentoo/${P}.tgz"
LICENSE="VPL-1.0"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc alpha ~hppa amd64"
+KEYWORDS="alpha amd64 hppa ~ppc ~sparc x86"
IUSE=""
+
DEPEND=""
+
S=${WORKDIR}/freenet6-client-1.0
src_unpack() {
unpack ${A}
cd ${S}
-
- mv -f src/Makefile ${T}
- sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
- ${T}/Makefile > src/Makefile
+ sed -i \
+ -e "s:gcc -g -I\$(INC) -Wall:$(tc-getCC) -I\$(INC) ${CFLAGS}:" \
+ src/Makefile
}
src_compile() {
@@ -27,7 +30,7 @@ src_compile() {
}
src_install() {
- dosbin bin/tspc
+ dosbin bin/tspc || die
insopts -m 600
insinto /etc/freenet6
diff --git a/net-misc/host/host-991529.ebuild b/net-misc/host/host-991529.ebuild
index 15465073f2b1..46061da8c2b6 100644
--- a/net-misc/host/host-991529.ebuild
+++ b/net-misc/host/host-991529.ebuild
@@ -1,36 +1,40 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/host/host-991529.ebuild,v 1.23 2004/07/15 02:52:20 agriffis Exp $
-
-S="${WORKDIR}"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/host/host-991529.ebuild,v 1.24 2004/10/26 14:23:13 vapier Exp $
# This is somewhat old tool, has not been changed since 1999,
# Still looks like host from bind does not provide all possible functionality
# at least xtraceroute wants LOC support, which is provided by this tool.
-DESCRIPTION="the standalone host tool, supports LOC reporting (RFC1876)"
+
# This is the homepage for xtraceroute, not host, but that's best I can do -
# at least it is mentioned there.
+
+inherit toolchain-funcs
+
+DESCRIPTION="the standalone host tool, supports LOC reporting (RFC1876)"
HOMEPAGE="http://www.dtek.chalmers.se/~d3august/xt/"
SRC_URI="ftp://ftp.ripe.net/tools/dns/${PN}.tar.Z"
-KEYWORDS="x86 ppc sparc alpha mips hppa amd64 ppc64"
-IUSE=""
LICENSE="as-is"
SLOT="0"
+KEYWORDS="alpha amd64 hppa mips ppc ppc64 sparc x86"
+IUSE=""
DEPEND=">=sys-apps/sed-4"
+S="${WORKDIR}"
+
src_unpack() {
cd ${S}
unpack ${A}
- sed -i -e "s:staff:root:" Makefile || \
- die "sed Makefile failed"
+ sed -i -e "s:staff:root:" Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
- emake CC="${CC}" COPTS="${CFLAGS}" || \
- die "emake failed"
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}" \
+ || die "emake failed"
# ATTN!
# This util has slightly different format of output from "standard" host
# rename it to hostx, hopefully this does not conflict with anything.
@@ -40,7 +44,7 @@ src_compile() {
src_install () {
cd ${WORKDIR}
- dobin hostx || die "dobin failed"
- doman hostx.1 || die "doman failed"
- dodoc RE* || die "dodoc failed"
+ dobin hostx || die "dobin failed"
+ doman hostx.1
+ dodoc RE*
}
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
index 01406492d9ab..c0deb037b4ec 100644
--- a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
@@ -1,35 +1,34 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild,v 1.6 2004/09/03 14:00:54 dholm Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild,v 1.7 2004/10/26 14:24:39 vapier Exp $
DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
-
-SRC_URI="http://home.t-online.de/home/gerd.o/netpipe.tar.gz"
HOMEPAGE="http://home.t-online.de/home/gerd.o/netpipe.html"
+SRC_URI="http://home.t-online.de/home/gerd.o/netpipe.tar.gz"
-DEPEND="virtual/libc"
-
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc"
S="${WORKDIR}/netpipe"
src_unpack() {
- unpack ${A} ; cd ${S}
- mv Makefile Makefile.orig
- sed -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
- -e "s:^#CC.*:CC = gcc:" \
- Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
+ -e "s:^#CC.*:CC = $(tc-getCC):" \
+ Makefile
}
src_compile() {
make || die
}
-src_install () {
- dobin netpipe
+src_install() {
+ dobin netpipe || die
dodoc DOCUMENTATION INSTALL TECH-NOTES
}