summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-06-21 15:04:06 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-06-21 15:04:06 +0000
commite951688154c423445823d5ca6e980a8618bf2088 (patch)
tree7906e820f74ba484956abc32bec8f37e9b425f6b /net-misc/ndtpd
parentstable x86, security bug 226059 (diff)
downloadgentoo-2-e951688154c423445823d5ca6e980a8618bf2088.tar.gz
gentoo-2-e951688154c423445823d5ca6e980a8618bf2088.tar.bz2
gentoo-2-e951688154c423445823d5ca6e980a8618bf2088.zip
Use autotools.eclass instead of calling autoconf directly. Fix conflicting
types build error for canonicalize_file_name. Clean up ebuild. (Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'net-misc/ndtpd')
-rw-r--r--net-misc/ndtpd/ChangeLog9
-rw-r--r--net-misc/ndtpd/files/ndtpd-3.1.5-canonicalize.patch12
-rw-r--r--net-misc/ndtpd/ndtpd-3.1.5.ebuild24
3 files changed, 29 insertions, 16 deletions
diff --git a/net-misc/ndtpd/ChangeLog b/net-misc/ndtpd/ChangeLog
index 299b12142976..6ae7f1cba32b 100644
--- a/net-misc/ndtpd/ChangeLog
+++ b/net-misc/ndtpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ndtpd
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ChangeLog,v 1.15 2007/12/25 17:13:26 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ChangeLog,v 1.16 2008/06/21 15:04:05 dirtyepic Exp $
+
+ 21 Jun 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/ndtpd-3.1.5-canonicalize.patch, ndtpd-3.1.5.ebuild:
+ Use autotools.eclass instead of calling autoconf directly. Fix conflicting
+ types build error for canonicalize_file_name. Clean up ebuild.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931. Assigning to maintainer-needed.
diff --git a/net-misc/ndtpd/files/ndtpd-3.1.5-canonicalize.patch b/net-misc/ndtpd/files/ndtpd-3.1.5-canonicalize.patch
new file mode 100644
index 000000000000..92889a41401f
--- /dev/null
+++ b/net-misc/ndtpd/files/ndtpd-3.1.5-canonicalize.patch
@@ -0,0 +1,12 @@
+diff -Naurp ndtpd-3.1.5-orig/lib/filename.h ndtpd-3.1.5/lib/filename.h
+--- ndtpd-3.1.5-orig/lib/filename.h 2001-02-03 03:36:06.000000000 -0600
++++ ndtpd-3.1.5/lib/filename.h 2008-06-21 08:34:18.000000000 -0600
+@@ -25,7 +25,7 @@
+ * Function declarations.
+ */
+ #ifdef __STDC__
+-int canonicalize_file_name(char *);
++char * canonicalize_file_name(const char *);
+ #else
+ int canonicalize_file_name();
+ #endif
diff --git a/net-misc/ndtpd/ndtpd-3.1.5.ebuild b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
index 5ee24cb7b2c9..346b00038029 100644
--- a/net-misc/ndtpd/ndtpd-3.1.5.ebuild
+++ b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ndtpd-3.1.5.ebuild,v 1.13 2007/12/04 10:02:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ndtpd-3.1.5.ebuild,v 1.14 2008/06/21 15:04:05 dirtyepic Exp $
-inherit eutils
+inherit autotools eutils
IUSE=""
@@ -14,10 +14,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-RDEPEND=">=dev-libs/eb-3
- >=sys-libs/zlib-1.1.3-r2"
+DEPEND="${RDEPEND}"
+RDEPEND=">=dev-libs/eb-3"
pkg_setup() {
# this is required; src_install() needs ndtpuser:ndtpgrp
@@ -26,23 +24,21 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-eb4-gentoo.diff"
+ epatch "${FILESDIR}"/${P}-canonicalize.patch
+ eautoreconf
}
src_compile() {
-
- autoconf || die
-
- econf --with-eb-conf=/etc/eb.conf || die
- emake || die
+ econf --with-eb-conf=/etc/eb.conf || die "Failed during configure."
+ emake || die "Failed during make."
}
src_install() {
- einstall || die
+ emake DESTDIR="${D}" install || die "Failed during install."
newinitd "${FILESDIR}/ndtpd.initd" ndtpd