summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ndtpd/ndtpd-3.1.5.ebuild')
-rw-r--r--net-misc/ndtpd/ndtpd-3.1.5.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-misc/ndtpd/ndtpd-3.1.5.ebuild b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
index 5ee24cb7b2c9..346b00038029 100644
--- a/net-misc/ndtpd/ndtpd-3.1.5.ebuild
+++ b/net-misc/ndtpd/ndtpd-3.1.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ndtpd-3.1.5.ebuild,v 1.13 2007/12/04 10:02:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndtpd/ndtpd-3.1.5.ebuild,v 1.14 2008/06/21 15:04:05 dirtyepic Exp $
-inherit eutils
+inherit autotools eutils
IUSE=""
@@ -14,10 +14,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~amd64"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-RDEPEND=">=dev-libs/eb-3
- >=sys-libs/zlib-1.1.3-r2"
+DEPEND="${RDEPEND}"
+RDEPEND=">=dev-libs/eb-3"
pkg_setup() {
# this is required; src_install() needs ndtpuser:ndtpgrp
@@ -26,23 +24,21 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-eb4-gentoo.diff"
+ epatch "${FILESDIR}"/${P}-canonicalize.patch
+ eautoreconf
}
src_compile() {
-
- autoconf || die
-
- econf --with-eb-conf=/etc/eb.conf || die
- emake || die
+ econf --with-eb-conf=/etc/eb.conf || die "Failed during configure."
+ emake || die "Failed during make."
}
src_install() {
- einstall || die
+ emake DESTDIR="${D}" install || die "Failed during install."
newinitd "${FILESDIR}/ndtpd.initd" ndtpd