summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2002-06-25 20:18:29 +0000
committerPhil Bordelon <sunflare@gentoo.org>2002-06-25 20:18:29 +0000
commita6cb757c103d7082e0d941bbc551eb3cb84114cb (patch)
treead2b36e84cc18a8a74f244aea3015c68ef27f329 /net-im
parentadding gtk+licq (diff)
downloadgentoo-2-a6cb757c103d7082e0d941bbc551eb3cb84114cb.tar.gz
gentoo-2-a6cb757c103d7082e0d941bbc551eb3cb84114cb.tar.bz2
gentoo-2-a6cb757c103d7082e0d941bbc551eb3cb84114cb.zip
Updating SILC to the latest version. Cleaned up the ebuild as well.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-client/ChangeLog8
-rw-r--r--net-im/silc-client/files/digest-silc-client-0.9.41
-rw-r--r--net-im/silc-client/silc-client-0.9.4.ebuild58
3 files changed, 66 insertions, 1 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index 6f81db8fc78a..e3a419d1de3f 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.2 2002/05/19 23:48:05 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.3 2002/06/25 20:18:29 sunflare Exp $
+
+*silc-client-0.9.4 (25 Jun 2002)
+
+ 25 Jun 2002; Phil Bordelon <sunflare@gentoo.org> silc-client-0.9.4.ebuild :
+
+ Version bump. Cleaned up the build to match current standards as well.
*silc-client-0.9.1 (19 May 2002)
diff --git a/net-im/silc-client/files/digest-silc-client-0.9.4 b/net-im/silc-client/files/digest-silc-client-0.9.4
new file mode 100644
index 000000000000..34d8900966c9
--- /dev/null
+++ b/net-im/silc-client/files/digest-silc-client-0.9.4
@@ -0,0 +1 @@
+MD5 55edd3c53479effc257cf00c07df12d2 silc-client-0.9.4.tar.bz2 1394004
diff --git a/net-im/silc-client/silc-client-0.9.4.ebuild b/net-im/silc-client/silc-client-0.9.4.ebuild
new file mode 100644
index 000000000000..966af1fd5945
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An IRSSI-based text client for Secure Internet Live Conferencing."
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ perl? ( sys-devel/perl )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ myconf="--with-ncurses"
+
+ if [ "`use ipv6`" ]; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ if [ "`use socks5`" ]; then
+ myconf="${myconf} --with-socks5"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ rmdir ${D}/usr/include
+}
+