summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/silc-client/silc-client-0.9.4.ebuild')
-rw-r--r--net-im/silc-client/silc-client-0.9.4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-im/silc-client/silc-client-0.9.4.ebuild b/net-im/silc-client/silc-client-0.9.4.ebuild
new file mode 100644
index 000000000000..966af1fd5945
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An IRSSI-based text client for Secure Internet Live Conferencing."
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ perl? ( sys-devel/perl )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ myconf="--with-ncurses"
+
+ if [ "`use ipv6`" ]; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ if [ "`use socks5`" ]; then
+ myconf="${myconf} --with-socks5"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ rmdir ${D}/usr/include
+}
+