summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:03:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:03:50 +0000
commitc2e2dd2519030b5de6339a15f2582cc7c60568a0 (patch)
tree412f3b66429b368db28f4c3c7ae85404088fb662 /net-fs
parentadded bison-1.75 to package.mask (diff)
downloadgentoo-2-c2e2dd2519030b5de6339a15f2582cc7c60568a0.tar.gz
gentoo-2-c2e2dd2519030b5de6339a15f2582cc7c60568a0.tar.bz2
gentoo-2-c2e2dd2519030b5de6339a15f2582cc7c60568a0.zip
nls and pam use flag check
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/ncpfs/ChangeLog12
-rw-r--r--net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r11
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild36
3 files changed, 45 insertions, 4 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index 7cc3ce2d8d8a..2313505e940d 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,13 +1,17 @@
# ChangeLog for net-fs/ncpfs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author Heiko Helmle <helman@gmx.net>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.1 2002/06/20 16:46:56 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.2 2002/10/20 22:03:50 seemant Exp $
+
+*ncpfs-2.2.0.19 (20 Oct 2002)
+
+ 20 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ncpfs-2.2.0.19-r1.ebuild
+ files/digest-ncpfs-2.2.0.19-r1 :
+
+ Some fixes for NLS and PAM use flags.
*ncpfs-2.2.0.19 (20 Jun 2002)
20 Jun 2002; J.Alberto S.L. <bass@gentoo.org> ncpfs-2.2.0.19.ebuild:
First relase.
-
-
-
diff --git a/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r1 b/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r1
new file mode 100644
index 000000000000..c547999575bf
--- /dev/null
+++ b/net-fs/ncpfs/files/digest-ncpfs-2.2.0.19-r1
@@ -0,0 +1 @@
+MD5 edaa6df0b892f0948e543b592eca36d3 ncpfs-2.2.0.19.tar.gz 1465012
diff --git a/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild b/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild
new file mode 100644
index 000000000000..80454363e80a
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild
@@ -0,0 +1,36 @@
+#Copyright 2002 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild,v 1.1 2002/10/20 22:03:50 seemant Exp $
+
+IUSE="nls pam"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/latest/${P}.tar.gz"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/latest/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )
+ pam? ( sys-libs/pam )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use pam \
+ && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install () {
+ # directory ${D}/lib/security needs to be created or the install fails
+ dodir /lib/security
+ make DESTDIR=${D} install || die
+}