summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild')
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild b/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild
new file mode 100644
index 000000000000..80454363e80a
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild
@@ -0,0 +1,36 @@
+#Copyright 2002 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.0.19-r1.ebuild,v 1.1 2002/10/20 22:03:50 seemant Exp $
+
+IUSE="nls pam"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Provides Access to Netware services using the NCP protocol (Kernel support must be activated!)"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/latest/${P}.tar.gz"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/latest/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="nls? ( sys-devel/gettext )
+ pam? ( sys-libs/pam )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use pam \
+ && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install () {
+ # directory ${D}/lib/security needs to be created or the install fails
+ dodir /lib/security
+ make DESTDIR=${D} install || die
+}