summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 01:33:30 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 01:33:30 +0000
commita48915bea7e89a56182f76c0683551ca3937c776 (patch)
tree30bb847341e934cae4ab4c069f9fd55ddae94123 /net-dialup/fcdsl/fcdsl-0.1.ebuild
parentAdded patch to fix compilation on ppc, bug #200866. (diff)
downloadgentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.tar.gz
gentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.tar.bz2
gentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.zip
using special openSUSE repository for AVM drivers from now on.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-dialup/fcdsl/fcdsl-0.1.ebuild')
-rw-r--r--net-dialup/fcdsl/fcdsl-0.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-dialup/fcdsl/fcdsl-0.1.ebuild b/net-dialup/fcdsl/fcdsl-0.1.ebuild
new file mode 100644
index 000000000000..0edcd25ff206
--- /dev/null
+++ b/net-dialup/fcdsl/fcdsl-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-0.1.ebuild,v 1.1 2008/01/06 01:33:29 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card DSL PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins *.bin
+ dodoc CAPI*.txt
+ dohtml *.html
+}