summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 01:33:30 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 01:33:30 +0000
commita48915bea7e89a56182f76c0683551ca3937c776 (patch)
tree30bb847341e934cae4ab4c069f9fd55ddae94123 /net-dialup
parentAdded patch to fix compilation on ppc, bug #200866. (diff)
downloadgentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.tar.gz
gentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.tar.bz2
gentoo-2-a48915bea7e89a56182f76c0683551ca3937c776.zip
using special openSUSE repository for AVM drivers from now on.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/fcdsl/ChangeLog10
-rw-r--r--net-dialup/fcdsl/fcdsl-0.1.ebuild48
-rw-r--r--net-dialup/fcdsl/files/digest-fcdsl-0.13
-rw-r--r--net-dialup/fcdsl/metadata.xml6
4 files changed, 64 insertions, 3 deletions
diff --git a/net-dialup/fcdsl/ChangeLog b/net-dialup/fcdsl/ChangeLog
index 1f9fb2086857..9b3e251a52e7 100644
--- a/net-dialup/fcdsl/ChangeLog
+++ b/net-dialup/fcdsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/fcdsl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.33 2007/12/25 20:27:53 genstef Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/ChangeLog,v 1.34 2008/01/06 01:33:29 sbriesen Exp $
+
+*fcdsl-0.1 (06 Jan 2008)
+
+ 06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org> metadata.xml,
+ +fcdsl-0.1.ebuild:
+ using special openSUSE repository for AVM drivers from now on.
25 Dec 2007; Stefan Schweizer <genstef@gentoo.org> fcdsl-2.6.37.ebuild:
fix patch ordering
diff --git a/net-dialup/fcdsl/fcdsl-0.1.ebuild b/net-dialup/fcdsl/fcdsl-0.1.ebuild
new file mode 100644
index 000000000000..0edcd25ff206
--- /dev/null
+++ b/net-dialup/fcdsl/fcdsl-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdsl/fcdsl-0.1.ebuild,v 1.1 2008/01/06 01:33:29 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card DSL PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins *.bin
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcdsl/files/digest-fcdsl-0.1 b/net-dialup/fcdsl/files/digest-fcdsl-0.1
new file mode 100644
index 000000000000..2a62b5c51d8d
--- /dev/null
+++ b/net-dialup/fcdsl/files/digest-fcdsl-0.1
@@ -0,0 +1,3 @@
+MD5 efb65ee7a21571155219e3896579378a fcdsl-0.1-0.src.rpm 1792277
+RMD160 16cb511dffe8e9d773b382713da8fcca2b2be0b8 fcdsl-0.1-0.src.rpm 1792277
+SHA256 00f2a5b3abb072edc00447308b4680b044efbcbd9d8844060a36509c9cc3064c fcdsl-0.1-0.src.rpm 1792277
diff --git a/net-dialup/fcdsl/metadata.xml b/net-dialup/fcdsl/metadata.xml
index 1e11e7bbd01b..5c648b8ae7af 100644
--- a/net-dialup/fcdsl/metadata.xml
+++ b/net-dialup/fcdsl/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-dialup</herd>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
</pkgmetadata>