summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-01 05:44:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-01 05:44:04 +0000
commite7cd3ad3d65291fd9e4034d14b33f5e2eaaad116 (patch)
tree6fbdb71719a4134a2cb61404bf817b0834fc966f /net-analyzer/iptraf/files
parentamd64 love (diff)
downloadgentoo-2-e7cd3ad3d65291fd9e4034d14b33f5e2eaaad116.tar.gz
gentoo-2-e7cd3ad3d65291fd9e4034d14b33f5e2eaaad116.tar.bz2
gentoo-2-e7cd3ad3d65291fd9e4034d14b33f5e2eaaad116.zip
Version bump #106775 by tonich/Tudor Alexandru Dragos.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-analyzer/iptraf/files')
-rw-r--r--net-analyzer/iptraf/files/digest-iptraf-3.0.01
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-atheros.patch42
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-build.patch31
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-linux-headers.patch41
4 files changed, 115 insertions, 0 deletions
diff --git a/net-analyzer/iptraf/files/digest-iptraf-3.0.0 b/net-analyzer/iptraf/files/digest-iptraf-3.0.0
new file mode 100644
index 000000000000..8fe4288f5b0a
--- /dev/null
+++ b/net-analyzer/iptraf/files/digest-iptraf-3.0.0
@@ -0,0 +1 @@
+MD5 377371c28ee3c21a76f7024920649ea8 iptraf-3.0.0.tar.gz 575169
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-atheros.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-atheros.patch
new file mode 100644
index 000000000000..a903cfda1a38
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-atheros.patch
@@ -0,0 +1,42 @@
+Add support for 'ath' interfaces
+
+--- iptraf-3.0.0/src/ifaces.c
++++ iptraf-3.0.0/src/ifaces.c
+@@ -32,14 +32,14 @@
+ #include "error.h"
+
+ extern int accept_unsupported_interfaces;
+-#define NUM_SUPPORTED_IFACES 26
++#define NUM_SUPPORTED_IFACES 27
+
+ extern int daemonized;
+
+ char ifaces[][6] =
+ { "lo", "eth", "sl", "ppp", "ippp", "plip", "fddi", "isdn", "dvb",
+ "pvc", "hdlc", "ipsec", "sbni", "tr", "wvlan", "wlan", "sm2", "sm3",
+- "pent", "lec", "brg", "tun", "tap", "cipcb", "tunl", "vlan"
++ "pent", "lec", "brg", "tun", "tap", "cipcb", "tunl", "vlan", "ath"
+ };
+
+ char *ltrim(char *buf)
+--- iptraf-3.0.0/src/packet.c
++++ iptraf-3.0.0/src/packet.c
+@@ -110,6 +110,8 @@
+ result = LINK_ETHERNET;
+ else if (strncmp(ifname, "tap", 3) == 0)
+ result = LINK_ETHERNET;
++ else if (strncmp(ifname, "ath", 3) == 0)
++ result = LINK_ETHERNET;
+ else if ((strncmp(ifname, "isdn", 4) == 0) && (isdn_fd != -1)) {
+ isdnent = isdn_table_lookup(isdnlist, ifname, isdn_fd);
+
+--- iptraf-3.0.0/src/promisc.c
++++ iptraf-3.0.0/src/promisc.c
+@@ -83,6 +83,7 @@
+ if ((strncmp(buf, "eth", 3) == 0) ||
+ (strncmp(buf, "fddi", 4) == 0) ||
+ (strncmp(buf, "tr", 2) == 0) ||
++ (strncmp(buf, "ath", 3) == 0) ||
+ (strncmp(ptmp->params.ifname, "wvlan", 4) == 0) ||
+ (strncmp(ptmp->params.ifname, "lec", 3) == 0) ||
+ (accept_unsupported_interfaces)) {
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch
new file mode 100644
index 000000000000..2e03d81398f0
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch
@@ -0,0 +1,31 @@
+--- src/Makefile
++++ src/Makefile
+@@ -6,7 +6,5 @@
+ # Architecture determination string borrowed from the kernel makefile.
+ #
+-ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+- -e s/arm.*/arm/ -e s/sa110/arm/)
+-PLATFORM = -DPLATFORM=\"$(shell uname -s)/$(ARCH)\"
++PLATFORM = -DPLATFORM=\"$(CHOST)\"
+ VERNUMBER := $(shell cat version)
+ VERSION = -DVERSION=\"$(VERNUMBER)\"
+@@ -38,5 +37,5 @@
+ # if the ncurses include files are not in the default location.
+
+-INCLUDEDIR = -I/usr/include/ncurses -I../support
++INCLUDEDIR = -I../support
+
+ # You can uncomment this one to disable the backspace key in input fields.
+--- support/Makefile
++++ support/Makefile
+@@ -1,3 +1,2 @@
+-INCLUDEDIR = -I/usr/include/ncurses
+
+ OBJS = input.o menurt.o listbox.o winops.o labels.o \
+@@ -13,5 +12,5 @@
+
+ %.o: %.c *.h
+- gcc -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
++ $(CC) $(CFLAGS) -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
+
+ clean:
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-linux-headers.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-linux-headers.patch
new file mode 100644
index 000000000000..0afffc037a50
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-linux-headers.patch
@@ -0,0 +1,41 @@
+--- iptraf-3.0.0/src/othptab.c
++++ iptraf-3.0.0/src/othptab.c
+@@ -17,8 +17,6 @@
+
+ #include <asm/types.h>
+ #include <linux/if_ether.h>
+-#include <linux/if_tr.h>
+-#include <linux/if_fddi.h>
+ #include <winops.h>
+ #include "arphdr.h"
+ #include "options.h"
+--- iptraf-3.0.0/src/packet.c
++++ iptraf-3.0.0/src/packet.c
+@@ -32,6 +32,9 @@
+ #include <sys/time.h>
+ #include <net/if_arp.h>
+ #include <net/if.h>
++#ifdef _NET_IF_H
++#define _LINUX_IF_H
++#endif
+ #include <sys/ioctl.h>
+ #include <linux/if_packet.h>
+ #include <linux/if_ether.h>
+--- iptraf-3.0.0/src/tcptable.h
++++ iptraf-3.0.0/src/tcptable.h
+@@ -20,11 +20,14 @@
+ #include <arpa/inet.h>
+ #include <net/if_arp.h>
+ #include <asm/types.h>
++#include <net/if.h>
++#ifdef _NET_IF_H
++#define _LINUX_IF_H
++#endif
+ #include <linux/if_packet.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_fddi.h>
+ #include <linux/if_tr.h>
+-#include <net/if.h>
+ #include <netinet/ip.h>
+ #include <netinet/udp.h>
+ #include "servname.h"