summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iptraf/files/iptraf-3.0.0-build.patch')
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-build.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch
new file mode 100644
index 000000000000..2e03d81398f0
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-build.patch
@@ -0,0 +1,31 @@
+--- src/Makefile
++++ src/Makefile
+@@ -6,7 +6,5 @@
+ # Architecture determination string borrowed from the kernel makefile.
+ #
+-ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+- -e s/arm.*/arm/ -e s/sa110/arm/)
+-PLATFORM = -DPLATFORM=\"$(shell uname -s)/$(ARCH)\"
++PLATFORM = -DPLATFORM=\"$(CHOST)\"
+ VERNUMBER := $(shell cat version)
+ VERSION = -DVERSION=\"$(VERNUMBER)\"
+@@ -38,5 +37,5 @@
+ # if the ncurses include files are not in the default location.
+
+-INCLUDEDIR = -I/usr/include/ncurses -I../support
++INCLUDEDIR = -I../support
+
+ # You can uncomment this one to disable the backspace key in input fields.
+--- support/Makefile
++++ support/Makefile
+@@ -1,3 +1,2 @@
+-INCLUDEDIR = -I/usr/include/ncurses
+
+ OBJS = input.o menurt.o listbox.o winops.o labels.o \
+@@ -13,5 +12,5 @@
+
+ %.o: %.c *.h
+- gcc -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
++ $(CC) $(CFLAGS) -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
+
+ clean: