summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-13 10:07:25 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-13 10:07:25 +0000
commit2fce00949c88e2b5a101cf976354dfd76ca7501d (patch)
treebac5907a49d58f67e4fd1a9d442ddefff9dce0af /media-sound/audacity
parentheader fix (Manifest recommit) (diff)
downloadgentoo-2-2fce00949c88e2b5a101cf976354dfd76ca7501d.tar.gz
gentoo-2-2fce00949c88e2b5a101cf976354dfd76ca7501d.tar.bz2
gentoo-2-2fce00949c88e2b5a101cf976354dfd76ca7501d.zip
readded wxgtk unicode check...
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog6
-rw-r--r--media-sound/audacity/audacity-1.2.0.ebuild12
2 files changed, 16 insertions, 2 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 227fb703b563..0c884483f789 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.18 2004/03/03 23:07:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.19 2004/03/13 10:07:25 eradicator Exp $
+
+ 13 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ audacity-1.2.0.ebuild:
+ readded wxgtk unicode check...
04 Mar 2004; David Holm <dholm@gentoo.org> audacity-1.2.0.ebuild:
Added to ~ppc.
diff --git a/media-sound/audacity/audacity-1.2.0.ebuild b/media-sound/audacity/audacity-1.2.0.ebuild
index 2ca470cdf57f..dad3532d37d5 100644
--- a/media-sound/audacity/audacity-1.2.0.ebuild
+++ b/media-sound/audacity/audacity-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.0.ebuild,v 1.2 2004/03/03 23:07:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.0.ebuild,v 1.3 2004/03/13 10:07:25 eradicator Exp $
inherit eutils
@@ -33,6 +33,16 @@ S="${WORKDIR}/${MY_P}"
DOC="LICENSE.txt README.txt audacity-1.2-help.htb"
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "Audacity will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
src_compile() {
local myconf;