summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audacity/audacity-1.2.0.ebuild')
-rw-r--r--media-sound/audacity/audacity-1.2.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-sound/audacity/audacity-1.2.0.ebuild b/media-sound/audacity/audacity-1.2.0.ebuild
index 2ca470cdf57f..dad3532d37d5 100644
--- a/media-sound/audacity/audacity-1.2.0.ebuild
+++ b/media-sound/audacity/audacity-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.0.ebuild,v 1.2 2004/03/03 23:07:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.0.ebuild,v 1.3 2004/03/13 10:07:25 eradicator Exp $
inherit eutils
@@ -33,6 +33,16 @@ S="${WORKDIR}/${MY_P}"
DOC="LICENSE.txt README.txt audacity-1.2-help.htb"
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "Audacity will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
src_compile() {
local myconf;