summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
commit5bfb813bc4698fcbb075d88cbb3bd2842db80a3a (patch)
tree7de747dbeeaa5f64144afa44e6c48a5aafd1b3d2 /media-plugins/mythgame
parentBump to version 0.12. (diff)
downloadgentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.tar.gz
gentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.tar.bz2
gentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.zip
Bump to version 0.12.
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest4
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.121
-rw-r--r--media-plugins/mythgame/mythgame-0.12.ebuild66
4 files changed, 76 insertions, 2 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 423877514556..13d96ce4528a 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.5 2003/09/17 06:25:29 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.6 2003/10/20 03:29:45 max Exp $
+
+*mythgame-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythgame-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythgame-0.10.ebuild,
mythgame-0.11.ebuild:
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 23930113b34e..998edb033147 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,6 +1,8 @@
+MD5 45714882d59bc417af1b2ea8bacdad69 mythgame-0.12.ebuild 1962
MD5 3c46ea652d6e76a76eb15e34026c4777 mythgame-0.11.ebuild 1976
MD5 4b17f8d2524f3c6ae4a41916793e7cfd mythgame-0.10.ebuild 2009
-MD5 cb7b77584f9fa8851fdcd3d2e81832ec ChangeLog 1574
+MD5 086b0297e963a7341ff4bb955f691514 ChangeLog 1694
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 9b0262b1d9e5347fceb6265378d7bf2e files/digest-mythgame-0.10 65
MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
+MD5 ace6a7f7f30d271f0c3e7bb1ea4ea89b files/digest-mythgame-0.12 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.12 b/media-plugins/mythgame/files/digest-mythgame-0.12
new file mode 100644
index 000000000000..6201852ae588
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.12
@@ -0,0 +1 @@
+MD5 10d5435d86b96a41244619079c860439 mythgame-0.12.tar.bz2 63386
diff --git a/media-plugins/mythgame/mythgame-0.12.ebuild b/media-plugins/mythgame/mythgame-0.12.ebuild
new file mode 100644
index 000000000000..6715f5403363
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.12.ebuild,v 1.1 2003/10/20 03:29:45 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}