summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
commit5bfb813bc4698fcbb075d88cbb3bd2842db80a3a (patch)
tree7de747dbeeaa5f64144afa44e6c48a5aafd1b3d2
parentBump to version 0.12. (diff)
downloadgentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.tar.gz
gentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.tar.bz2
gentoo-2-5bfb813bc4698fcbb075d88cbb3bd2842db80a3a.zip
Bump to version 0.12.
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest4
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.121
-rw-r--r--media-plugins/mythgame/mythgame-0.12.ebuild66
-rw-r--r--media-plugins/mythmusic/ChangeLog7
-rw-r--r--media-plugins/mythmusic/Manifest4
-rw-r--r--media-plugins/mythmusic/files/digest-mythmusic-0.121
-rw-r--r--media-plugins/mythmusic/mythmusic-0.12.ebuild77
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.121
-rw-r--r--media-plugins/mythweather/mythweather-0.12.ebuild39
12 files changed, 212 insertions, 6 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 423877514556..13d96ce4528a 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.5 2003/09/17 06:25:29 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.6 2003/10/20 03:29:45 max Exp $
+
+*mythgame-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythgame-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythgame-0.10.ebuild,
mythgame-0.11.ebuild:
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 23930113b34e..998edb033147 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,6 +1,8 @@
+MD5 45714882d59bc417af1b2ea8bacdad69 mythgame-0.12.ebuild 1962
MD5 3c46ea652d6e76a76eb15e34026c4777 mythgame-0.11.ebuild 1976
MD5 4b17f8d2524f3c6ae4a41916793e7cfd mythgame-0.10.ebuild 2009
-MD5 cb7b77584f9fa8851fdcd3d2e81832ec ChangeLog 1574
+MD5 086b0297e963a7341ff4bb955f691514 ChangeLog 1694
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 9b0262b1d9e5347fceb6265378d7bf2e files/digest-mythgame-0.10 65
MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
+MD5 ace6a7f7f30d271f0c3e7bb1ea4ea89b files/digest-mythgame-0.12 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.12 b/media-plugins/mythgame/files/digest-mythgame-0.12
new file mode 100644
index 000000000000..6201852ae588
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.12
@@ -0,0 +1 @@
+MD5 10d5435d86b96a41244619079c860439 mythgame-0.12.tar.bz2 63386
diff --git a/media-plugins/mythgame/mythgame-0.12.ebuild b/media-plugins/mythgame/mythgame-0.12.ebuild
new file mode 100644
index 000000000000..6715f5403363
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.12.ebuild,v 1.1 2003/10/20 03:29:45 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}
diff --git a/media-plugins/mythmusic/ChangeLog b/media-plugins/mythmusic/ChangeLog
index 9126f3cb6e5c..a90b506a6176 100644
--- a/media-plugins/mythmusic/ChangeLog
+++ b/media-plugins/mythmusic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythmusic
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/ChangeLog,v 1.7 2003/09/17 06:26:59 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/ChangeLog,v 1.8 2003/10/20 03:30:45 max Exp $
+
+*mythmusic-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythmusic-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythmusic-0.10.ebuild,
mythmusic-0.11.ebuild:
diff --git a/media-plugins/mythmusic/Manifest b/media-plugins/mythmusic/Manifest
index bb5c21a13f86..dfaa093900e8 100644
--- a/media-plugins/mythmusic/Manifest
+++ b/media-plugins/mythmusic/Manifest
@@ -1,6 +1,8 @@
+MD5 e4a847002be8ea0fc723b1033bbd1ea6 mythmusic-0.12.ebuild 2153
MD5 95f428155f470dbd515a99a40c6c51f2 mythmusic-0.11.ebuild 2167
MD5 b2c5248116b78c5c044ba25add5202bc mythmusic-0.10.ebuild 2126
-MD5 608d0c7ab0b9cb13b0ea573c2602e867 ChangeLog 1949
+MD5 7c346e6f8fa4eb588be6322ebf943897 ChangeLog 2071
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 b8be115d97584eae89ae3cca03f7de73 files/digest-mythmusic-0.10 67
MD5 d3782b76395f4d656284b24c9ee8e7b4 files/digest-mythmusic-0.11 67
+MD5 84fa19b3a9087c7357d9de3c374abee2 files/digest-mythmusic-0.12 67
diff --git a/media-plugins/mythmusic/files/digest-mythmusic-0.12 b/media-plugins/mythmusic/files/digest-mythmusic-0.12
new file mode 100644
index 000000000000..e3da303d57cc
--- /dev/null
+++ b/media-plugins/mythmusic/files/digest-mythmusic-0.12
@@ -0,0 +1 @@
+MD5 04afe787b0dea4092abc1aced3e58d2e mythmusic-0.12.tar.bz2 198951
diff --git a/media-plugins/mythmusic/mythmusic-0.12.ebuild b/media-plugins/mythmusic/mythmusic-0.12.ebuild
new file mode 100644
index 000000000000..8507eac8255a
--- /dev/null
+++ b/media-plugins/mythmusic/mythmusic-0.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/mythmusic-0.12.ebuild,v 1.1 2003/10/20 03:30:45 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Music player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl sdl X"
+
+DEPEND=">=media-sound/cdparanoia-3.9.8
+ >=media-libs/libmad-0.14.2b
+ >=media-libs/libid3tag-0.14.2b
+ >=media-libs/libvorbis-1.0
+ >=media-libs/libcdaudio-0.99.6
+ >=media-libs/flac-1.1.0
+ >=sys-apps/sed-4
+ X? ( =dev-libs/fftw-2* )
+ opengl? ( virtual/opengl =dev-libs/fftw-2* )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_enable X fftw`"
+ myconf="${myconf} `use_enable opengl`"
+ myconf="${myconf} `use_enable sdl`"
+
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins musicdb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc musicdb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythMusic,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+}
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index c19b58b53685..9ff01125c0c0 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.5 2003/09/17 06:29:50 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.6 2003/10/20 03:34:29 max Exp $
+
+*mythweather-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythweather-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythweather-0.10.ebuild,
mythweather-0.11.ebuild:
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 958f21675523..03d03fe5b776 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,6 +1,8 @@
+MD5 5230ef18d7189354c4925becd1247dc0 mythweather-0.12.ebuild 962
MD5 103f2dc2a77568b205f86d9f8a21e4a8 mythweather-0.11.ebuild 972
MD5 d7ca666cb6cccf06ea43cd7a48ae62ee mythweather-0.10.ebuild 1005
-MD5 aebc302937c8337e949829ef751bb0e7 ChangeLog 1460
+MD5 8d11231e8a232a429760dc93f1567cc5 ChangeLog 1586
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 09666f4a410bc5eda6781edd029505f7 files/digest-mythweather-0.10 69
MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
+MD5 916ba5d7844b0abae782627b8d1a21fe files/digest-mythweather-0.12 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.12 b/media-plugins/mythweather/files/digest-mythweather-0.12
new file mode 100644
index 000000000000..14f49fcf11a2
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.12
@@ -0,0 +1 @@
+MD5 8daad867e4eaf04506401975647d6144 mythweather-0.12.tar.bz2 824577
diff --git a/media-plugins/mythweather/mythweather-0.12.ebuild b/media-plugins/mythweather/mythweather-0.12.ebuild
new file mode 100644
index 000000000000..e6cb52656f81
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.12.ebuild,v 1.1 2003/10/20 03:34:29 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}