summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-13 03:02:17 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-13 03:02:17 +0000
commit0471efe294988f06994f1c9bc29e82e69650151f (patch)
treee915f7310d9ae2ba25bebd5ed8a880dc75939265 /media-libs/yiff/files/yiff-2.14.2-PIC.patch
parentbug #56824. (Manifest recommit) (diff)
downloadgentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.tar.gz
gentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.tar.bz2
gentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.zip
Added USE=alsa support. Added PIC patch. Added ~amd64.
Diffstat (limited to 'media-libs/yiff/files/yiff-2.14.2-PIC.patch')
-rw-r--r--media-libs/yiff/files/yiff-2.14.2-PIC.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/yiff/files/yiff-2.14.2-PIC.patch b/media-libs/yiff/files/yiff-2.14.2-PIC.patch
new file mode 100644
index 000000000000..eae247c0447b
--- /dev/null
+++ b/media-libs/yiff/files/yiff-2.14.2-PIC.patch
@@ -0,0 +1,30 @@
+diff -Naur yiff-2.14.2.orig/libY2/Makefile yiff-2.14.2/libY2/Makefile
+--- yiff-2.14.2.orig/libY2/Makefile 2003-08-06 14:04:35.000000000 -0700
++++ yiff-2.14.2/libY2/Makefile 2004-07-12 19:56:22.000000000 -0700
+@@ -136,9 +136,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS) -fPIC -DPIC
+ .cpp.o:
+- +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS) -fPIC -DPIC
+
+ $(LIB): $(OBJ_C) $(OBJ_CPP)
+ $(CPP) $(OBJ_C) $(OBJ_CPP) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
+diff -Naur yiff-2.14.2.orig/libY2/Makefile.Linux yiff-2.14.2/libY2/Makefile.Linux
+--- yiff-2.14.2.orig/libY2/Makefile.Linux 2003-08-06 14:04:35.000000000 -0700
++++ yiff-2.14.2/libY2/Makefile.Linux 2004-07-12 19:58:37.000000000 -0700
+@@ -136,9 +136,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS) -fPIC -DPIC
+ .cpp.o:
+- +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS) -fPIC -DPIC
+
+ $(LIB): $(OBJ_C) $(OBJ_CPP)
+ $(CPP) $(OBJ_C) $(OBJ_CPP) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)