summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-13 03:02:17 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-13 03:02:17 +0000
commit0471efe294988f06994f1c9bc29e82e69650151f (patch)
treee915f7310d9ae2ba25bebd5ed8a880dc75939265 /media-libs/yiff
parentbug #56824. (Manifest recommit) (diff)
downloadgentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.tar.gz
gentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.tar.bz2
gentoo-2-0471efe294988f06994f1c9bc29e82e69650151f.zip
Added USE=alsa support. Added PIC patch. Added ~amd64.
Diffstat (limited to 'media-libs/yiff')
-rw-r--r--media-libs/yiff/ChangeLog6
-rw-r--r--media-libs/yiff/files/yiff-2.14.2-PIC.patch30
-rw-r--r--media-libs/yiff/yiff-2.14.2.ebuild13
3 files changed, 43 insertions, 6 deletions
diff --git a/media-libs/yiff/ChangeLog b/media-libs/yiff/ChangeLog
index 45662a480106..ad1bac13bcf3 100644
--- a/media-libs/yiff/ChangeLog
+++ b/media-libs/yiff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/yiff
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/ChangeLog,v 1.6 2004/07/09 11:35:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/ChangeLog,v 1.7 2004/07/13 03:02:17 eradicator Exp $
+
+ 12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/yiff-2.14.2-PIC.patch:
+ Added USE=alsa support. Added PIC patch. Added ~amd64.
09 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> yiff-2.14.2.ebuild:
Removing mikmod dependency stuff as it is borked... does not provide libkmid.h
diff --git a/media-libs/yiff/files/yiff-2.14.2-PIC.patch b/media-libs/yiff/files/yiff-2.14.2-PIC.patch
new file mode 100644
index 000000000000..eae247c0447b
--- /dev/null
+++ b/media-libs/yiff/files/yiff-2.14.2-PIC.patch
@@ -0,0 +1,30 @@
+diff -Naur yiff-2.14.2.orig/libY2/Makefile yiff-2.14.2/libY2/Makefile
+--- yiff-2.14.2.orig/libY2/Makefile 2003-08-06 14:04:35.000000000 -0700
++++ yiff-2.14.2/libY2/Makefile 2004-07-12 19:56:22.000000000 -0700
+@@ -136,9 +136,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS) -fPIC -DPIC
+ .cpp.o:
+- +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS) -fPIC -DPIC
+
+ $(LIB): $(OBJ_C) $(OBJ_CPP)
+ $(CPP) $(OBJ_C) $(OBJ_CPP) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
+diff -Naur yiff-2.14.2.orig/libY2/Makefile.Linux yiff-2.14.2/libY2/Makefile.Linux
+--- yiff-2.14.2.orig/libY2/Makefile.Linux 2003-08-06 14:04:35.000000000 -0700
++++ yiff-2.14.2/libY2/Makefile.Linux 2004-07-12 19:58:37.000000000 -0700
+@@ -136,9 +136,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ +$(CC) -c $*.c $(INC_DIRS) $(CFLAGS) -fPIC -DPIC
+ .cpp.o:
+- +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS) -fPIC -DPIC
+
+ $(LIB): $(OBJ_C) $(OBJ_CPP)
+ $(CPP) $(OBJ_C) $(OBJ_CPP) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
diff --git a/media-libs/yiff/yiff-2.14.2.ebuild b/media-libs/yiff/yiff-2.14.2.ebuild
index 458147da7947..380a65b17b9c 100644
--- a/media-libs/yiff/yiff-2.14.2.ebuild
+++ b/media-libs/yiff/yiff-2.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.2.ebuild,v 1.8 2004/07/09 11:35:12 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.2.ebuild,v 1.9 2004/07/13 03:02:17 eradicator Exp $
inherit flag-o-matic eutils kde
@@ -10,22 +10,25 @@ SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc"
-IUSE="gtk"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
+IUSE="gtk alsa"
-DEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
+ !sparc? ( alsa? ( media-libs/alsa-lib ) )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-gcc3.patch
+ epatch ${FILESDIR}/${P}-PIC.patch
}
src_compile() {
local pkgs="libY2 yiff yiffutils"
use gtk && pkgs="${pkgs} yiffconfig" && append-flags `gtk-config --cflags`
#append-flags -DHAVE_LIBKMID
- append-flags -DALSA_RUN_CONFORM -DOSS -DOSS_BUFFRAG -DYSHM_SUPPORT -D__USE_BSD
+ use alsa && append-flags -DALSA_RUN_CONFORM
+ append-flags -DOSS -DOSS_BUFFRAG -DYSHM_SUPPORT -D__USE_BSD
make linux \
CFLAGS="${CFLAGS}" \
LINUX_DIRS="${pkgs}" \