summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-04-24 21:00:00 +0000
committerMarius Mauch <genone@gentoo.org>2006-04-24 21:00:00 +0000
commitcfa676d2d295c6305dc04d25b1c9c38b7bbff3a9 (patch)
tree67b626c9513f3ea65e3ddb3b23bc793b702bd05b /mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild
parentStable on sparc wrt #130624 (diff)
downloadgentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.tar.gz
gentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.tar.bz2
gentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.zip
Version bump necessary for sylpheed-claws-2.1.1
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild')
-rw-r--r--mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild
new file mode 100644
index 000000000000..f897886dacb8
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild,v 1.1 2006/04/24 21:00:00 genone Exp $
+
+MY_P="${P##sylpheed-claws-}"
+MY_PN="${PN##sylpheed-claws-}"
+SC_BASE="2.1.0"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="Plugin for sylpheed-claws to use perl to write filtering rules"
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+#SRC_URI="http://claws.sylpheed.org/downloads/${MY_PN}_plugin-${PV}_gtk2.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}
+ dev-lang/perl"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_PN}_plugin-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=sc_perl sc_perl.pod > sc_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman sc_perl.1
+
+ cd tools
+ exeinto /usr/lib/sylpheed-claws/tools
+ doexe *.pl
+
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ einfo "The documentation for this plugin is contained in a manpage."
+ einfo "You can access it with 'man sc_perl'"
+}