summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-04-24 21:00:00 +0000
committerMarius Mauch <genone@gentoo.org>2006-04-24 21:00:00 +0000
commitcfa676d2d295c6305dc04d25b1c9c38b7bbff3a9 (patch)
tree67b626c9513f3ea65e3ddb3b23bc793b702bd05b /mail-client/sylpheed-claws-perl
parentStable on sparc wrt #130624 (diff)
downloadgentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.tar.gz
gentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.tar.bz2
gentoo-2-cfa676d2d295c6305dc04d25b1c9c38b7bbff3a9.zip
Version bump necessary for sylpheed-claws-2.1.1
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'mail-client/sylpheed-claws-perl')
-rw-r--r--mail-client/sylpheed-claws-perl/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.93
-rw-r--r--mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild49
3 files changed, 59 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws-perl/ChangeLog b/mail-client/sylpheed-claws-perl/ChangeLog
index bc2e0de7af89..761e04e5a178 100644
--- a/mail-client/sylpheed-claws-perl/ChangeLog
+++ b/mail-client/sylpheed-claws-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws-perl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.5 2006/04/17 18:38:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/ChangeLog,v 1.6 2006/04/24 21:00:00 genone Exp $
+
+*sylpheed-claws-perl-0.9 (24 Apr 2006)
+
+ 24 Apr 2006; Marius Mauch <genone@gentoo.org>
+ +sylpheed-claws-perl-0.9.ebuild:
+ Version bump necessary for sylpheed-claws-2.1.1
17 Apr 2006; Markus Rothe <corsair@gentoo.org>
sylpheed-claws-perl-0.6.ebuild:
diff --git a/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9 b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9
new file mode 100644
index 000000000000..7ff8d239e0fb
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/files/digest-sylpheed-claws-perl-0.9
@@ -0,0 +1,3 @@
+MD5 c15f7bd52ebed8c9c9163c8a8e593c5d sylpheed-claws-extra-plugins-2.1.0.tar.bz2 3769926
+RMD160 ca36b8b7972dd3e9f8ad843945fa377662819ac7 sylpheed-claws-extra-plugins-2.1.0.tar.bz2 3769926
+SHA256 3972f32bb37cd20da4489b18d886db9e1970231e39cf590570b2fa6f43013a71 sylpheed-claws-extra-plugins-2.1.0.tar.bz2 3769926
diff --git a/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild
new file mode 100644
index 000000000000..f897886dacb8
--- /dev/null
+++ b/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-perl/sylpheed-claws-perl-0.9.ebuild,v 1.1 2006/04/24 21:00:00 genone Exp $
+
+MY_P="${P##sylpheed-claws-}"
+MY_PN="${PN##sylpheed-claws-}"
+SC_BASE="2.1.0"
+SC_BASE_NAME="sylpheed-claws-extra-plugins-${SC_BASE}"
+
+DESCRIPTION="Plugin for sylpheed-claws to use perl to write filtering rules"
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${SC_BASE_NAME}.tar.bz2"
+#SRC_URI="http://claws.sylpheed.org/downloads/${MY_PN}_plugin-${PV}_gtk2.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}
+ dev-lang/perl"
+
+S="${WORKDIR}/${SC_BASE_NAME}/${MY_PN}_plugin-${PV}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=sc_perl sc_perl.pod > sc_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman sc_perl.1
+
+ cd tools
+ exeinto /usr/lib/sylpheed-claws/tools
+ doexe *.pl
+
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ einfo "The documentation for this plugin is contained in a manpage."
+ einfo "You can access it with 'man sc_perl'"
+}