summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:49:10 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:49:10 +0000
commit66b286dbf919abf202c9e1b2b64e3391402ecc71 (patch)
tree20a043403bc54199ca0be4278a5112379c639cc4 /kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild
parentVersion bump; remove old. (diff)
downloadgentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.tar.gz
gentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.tar.bz2
gentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.zip
Add upstream bugfixes
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild')
-rw-r--r--kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild b/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild
new file mode 100644
index 000000000000..34870066afff
--- /dev/null
+++ b/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild,v 1.1 2012/08/01 22:49:10 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+inherit kde4-meta
+
+DESCRIPTION="Personal alarm message, command and email scheduler for KDE"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim)
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+"
+
+KMEXTRACTONLY="
+ kmail/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.11.1-underlinking.patch"
+ "${FILESDIR}/4.4/"000{1,3,6}-*.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_akonadi=OFF
+ -DXSLTPROC_EXECUTABLE="${EPREFIX}"/usr/bin/xsltproc
+ )
+ kde4-meta_src_configure
+}