summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:49:10 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-01 22:49:10 +0000
commit66b286dbf919abf202c9e1b2b64e3391402ecc71 (patch)
tree20a043403bc54199ca0be4278a5112379c639cc4 /kde-base
parentVersion bump; remove old. (diff)
downloadgentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.tar.gz
gentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.tar.bz2
gentoo-2-66b286dbf919abf202c9e1b2b64e3391402ecc71.zip
Add upstream bugfixes
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kalarm/ChangeLog11
-rw-r--r--kde-base/kalarm/files/4.4/0001-Bug-266082-highlight-alarm-when-message-window-KAlar.patch146
-rw-r--r--kde-base/kalarm/files/4.4/0003-Bug-271580-Fix-crash-displaying-New-Alarm-dialog-fro.patch64
-rw-r--r--kde-base/kalarm/files/4.4/0006-Bug-296383-during-startup-check-that-resources-calen.patch123
-rw-r--r--kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild39
5 files changed, 382 insertions, 1 deletions
diff --git a/kde-base/kalarm/ChangeLog b/kde-base/kalarm/ChangeLog
index 14dbae47f3aa..cb9079a79ba6 100644
--- a/kde-base/kalarm/ChangeLog
+++ b/kde-base/kalarm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kalarm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.215 2012/08/01 22:17:17 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/ChangeLog,v 1.216 2012/08/01 22:49:10 dilfridge Exp $
+
+*kalarm-4.4.11.1-r2 (01 Aug 2012)
+
+ 01 Aug 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kalarm-4.4.11.1-r2.ebuild,
+ +files/4.4/0001-Bug-266082-highlight-alarm-when-message-window-KAlar.patch,
+ +files/4.4/0003-Bug-271580-Fix-crash-displaying-New-Alarm-dialog-fro.patch,
+ +files/4.4/0006-Bug-296383-during-startup-check-that-resources-calen.patch:
+ Add upstream bugfixes
*kalarm-4.9.0 (01 Aug 2012)
diff --git a/kde-base/kalarm/files/4.4/0001-Bug-266082-highlight-alarm-when-message-window-KAlar.patch b/kde-base/kalarm/files/4.4/0001-Bug-266082-highlight-alarm-when-message-window-KAlar.patch
new file mode 100644
index 000000000000..932f971c116a
--- /dev/null
+++ b/kde-base/kalarm/files/4.4/0001-Bug-266082-highlight-alarm-when-message-window-KAlar.patch
@@ -0,0 +1,146 @@
+From 712e45630ccd4ec128a087cb3de396b2df9e4ffc Mon Sep 17 00:00:00 2001
+From: David Jarvie <djarvie@kde.org>
+Date: Fri, 22 Apr 2011 00:36:20 +0100
+Subject: [PATCH 1/6] Bug 266082: highlight alarm when message window KAlarm
+ button clicked
+
+Fix the KAlarm button in the alarm window not always showing the main
+window, and not highlighting the alarm in the main window.
+---
+ kalarm/Changelog | 4 ++++
+ kalarm/eventlistview.cpp | 11 +++++++----
+ kalarm/eventlistview.h | 6 +++---
+ kalarm/functions.cpp | 11 +++--------
+ kalarm/kalarm.h | 2 +-
+ kalarm/mainwindow.cpp | 7 +------
+ 6 files changed, 19 insertions(+), 22 deletions(-)
+
+diff --git a/kalarm/Changelog b/kalarm/Changelog
+index 25569f4..fab5edf 100644
+--- a/kalarm/Changelog
++++ b/kalarm/Changelog
+@@ -1,5 +1,9 @@
+ KAlarm Change Log
+
++=== Version 2.4.12 --- 22 April 2011 ===
++- Fix KAlarm button in alarm window not always showing main window and not
++ highlighting the alarm in the main window.
++
+ === Version 2.4.11 (KDEPIM 4.4.11) --- 16 April 2011 ===
+ - Fix bad borders round left hand buttons of time spinboxes in Oxygen style.
+ - Fix initialisation of library global statics.
+diff --git a/kalarm/eventlistview.cpp b/kalarm/eventlistview.cpp
+index 75e8be8..0880c7f 100644
+--- a/kalarm/eventlistview.cpp
++++ b/kalarm/eventlistview.cpp
+@@ -1,7 +1,7 @@
+ /*
+ * eventlistview.cpp - base class for widget showing list of alarms
+ * Program: kalarm
+- * Copyright © 2007-2009 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2007-2009,2011 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -62,15 +62,18 @@ KAEvent* EventListView::event(int row) const
+
+ /******************************************************************************
+ * Select one event and make it the current item.
++* Optionally scroll to ensure that the event is visible.
+ */
+-void EventListView::select(const QString& eventId)
++void EventListView::select(const QString& eventId, bool scrollToEvent)
+ {
+- select(eventModel()->eventIndex(eventId));
++ select(eventModel()->eventIndex(eventId), scrollToEvent);
+ }
+
+-void EventListView::select(const QModelIndex& index)
++void EventListView::select(const QModelIndex& index, bool scrollToIndex)
+ {
+ selectionModel()->select(index, QItemSelectionModel::SelectCurrent | QItemSelectionModel::Rows);
++ if (scrollToIndex)
++ scrollTo(index);
+ }
+
+ /******************************************************************************
+diff --git a/kalarm/eventlistview.h b/kalarm/eventlistview.h
+index 23b97b1..f0dc7ca 100644
+--- a/kalarm/eventlistview.h
++++ b/kalarm/eventlistview.h
+@@ -1,7 +1,7 @@
+ /*
+ * eventlistview.h - base class for widget showing list of alarms
+ * Program: kalarm
+- * Copyright © 2007,2008 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2007,2008,2011 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -42,8 +42,8 @@ class EventListView : public QTreeView
+ EventListModel* eventModel() const { return static_cast<EventListModel*>(static_cast<QAbstractProxyModel*>(model())->sourceModel()); }
+ KAEvent* event(int row) const;
+ KAEvent* event(const QModelIndex&) const;
+- void select(const QString& eventId);
+- void select(const QModelIndex&);
++ void select(const QString& eventId, bool scrollToEvent = false);
++ void select(const QModelIndex&, bool scrollToIndex = false);
+ QModelIndex selectedIndex() const;
+ KAEvent* selectedEvent() const;
+ KAEvent::List selectedEvents() const;
+diff --git a/kalarm/functions.cpp b/kalarm/functions.cpp
+index ab1b6f1..307539a 100644
+--- a/kalarm/functions.cpp
++++ b/kalarm/functions.cpp
+@@ -132,14 +132,9 @@ MainWindow* displayMainWindowSelected(const QString& eventID)
+ else
+ {
+ // There is already a main window, so make it the active window
+- bool visible = win->isVisible();
+- if (visible)
+- win->hide(); // in case it's on a different desktop
+- if (!visible || win->isMinimized())
+- {
+- win->setWindowState(win->windowState() & ~Qt::WindowMinimized);
+- win->show();
+- }
++ win->hide(); // in case it's on a different desktop
++ win->setWindowState(win->windowState() & ~Qt::WindowMinimized);
++ win->show();
+ win->raise();
+ win->activateWindow();
+ }
+diff --git a/kalarm/kalarm.h b/kalarm/kalarm.h
+index 63333b2..e887eb3 100644
+--- a/kalarm/kalarm.h
++++ b/kalarm/kalarm.h
+@@ -23,7 +23,7 @@
+
+ #undef QT3_SUPPORT
+
+-#define KALARM_VERSION "2.4.11"
++#define KALARM_VERSION "2.4.12"
+ #define KALARM_NAME "KAlarm"
+ #define KALARM_DBUS_SERVICE "org.kde.kalarm" // D-Bus service name of KAlarm application
+
+diff --git a/kalarm/mainwindow.cpp b/kalarm/mainwindow.cpp
+index 95ce321..dd3b915 100644
+--- a/kalarm/mainwindow.cpp
++++ b/kalarm/mainwindow.cpp
+@@ -657,12 +657,7 @@ void MainWindow::updateKeepArchived(int days)
+ void MainWindow::selectEvent(const QString& eventID)
+ {
+ mListView->clearSelection();
+- QModelIndex index = EventListModel::alarms()->eventIndex(eventID);
+- if (index.isValid())
+- {
+- mListView->select(index);
+- mListView->scrollTo(index);
+- }
++ mListView->select(eventID, true);
+ }
+
+ /******************************************************************************
+--
+1.7.9.2
+
diff --git a/kde-base/kalarm/files/4.4/0003-Bug-271580-Fix-crash-displaying-New-Alarm-dialog-fro.patch b/kde-base/kalarm/files/4.4/0003-Bug-271580-Fix-crash-displaying-New-Alarm-dialog-fro.patch
new file mode 100644
index 000000000000..82fa7e3e8f6f
--- /dev/null
+++ b/kde-base/kalarm/files/4.4/0003-Bug-271580-Fix-crash-displaying-New-Alarm-dialog-fro.patch
@@ -0,0 +1,64 @@
+From 4b504e760e0c994e676b55bfaca731d74841f1f4 Mon Sep 17 00:00:00 2001
+From: David Jarvie <djarvie@kde.org>
+Date: Tue, 26 Apr 2011 23:29:19 +0100
+Subject: [PATCH 3/6] Bug 271580: Fix crash displaying New Alarm dialog from
+ system tray
+
+Fixes a crash on some systems when the New Alarm dialog is displayed
+from the system tray icon menu.
+---
+ kalarm/Changelog | 4 +++-
+ kalarm/lib/spinbox2.cpp | 9 +++++----
+ 2 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/kalarm/Changelog b/kalarm/Changelog
+index fab5edf..7caf1dd 100644
+--- a/kalarm/Changelog
++++ b/kalarm/Changelog
+@@ -1,6 +1,8 @@
+ KAlarm Change Log
+
+-=== Version 2.4.12 --- 22 April 2011 ===
++=== Version 2.4.12 --- 26 April 2011 ===
++- Fix crash on some systems when New Alarm dialogue is displayed from system tray
++ icon menu.
+ - Fix KAlarm button in alarm window not always showing main window and not
+ highlighting the alarm in the main window.
+
+diff --git a/kalarm/lib/spinbox2.cpp b/kalarm/lib/spinbox2.cpp
+index cc10882..f1e8ab9 100644
+--- a/kalarm/lib/spinbox2.cpp
++++ b/kalarm/lib/spinbox2.cpp
+@@ -1,7 +1,7 @@
+ /*
+ * spinbox2.cpp - spin box with extra pair of spin buttons (for Qt 3)
+ * Program: kalarm
+- * Copyright © 2001-2009 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2001-2009,2011 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -28,7 +28,7 @@
+ #include <QMouseEvent>
+ #include <QStyleOptionSpinBox>
+ #include <QGraphicsPixmapItem>
+-#include <QPaintEngine>
++#include <QPainter>
+ #include <QTimer>
+ #include <QFrame>
+ #include <QBrush>
+@@ -588,8 +588,9 @@ void SpinMirror::setFrame()
+ p = grabWidget(mMainSpinbox, QRect(x, 0, 1, height()));
+ // Blot out edit field stuff from the middle of the slice
+ QPixmap dot = grabWidget(mMainSpinbox, QRect(x, editOffsetY, 1, 1));
+- QPaintEngine* pe = p.paintEngine();
+- pe->drawTiledPixmap(QRectF(0, editOffsetY, 1, height() - 2*editOffsetY), dot, QPointF(0, 0));
++ QPainter painter(&p);
++ painter.drawTiledPixmap(0, editOffsetY, 1, height() - 2*editOffsetY, dot, 0, 0);
++ painter.end();
+ // Horizontally fill the mirror widget with the vertical slice
+ p = p.scaled(size());
+ // Grab the left hand border of the main spinbox, and draw it into the mirror widget.
+--
+1.7.9.2
+
diff --git a/kde-base/kalarm/files/4.4/0006-Bug-296383-during-startup-check-that-resources-calen.patch b/kde-base/kalarm/files/4.4/0006-Bug-296383-during-startup-check-that-resources-calen.patch
new file mode 100644
index 000000000000..6e75d0ca3e4e
--- /dev/null
+++ b/kde-base/kalarm/files/4.4/0006-Bug-296383-during-startup-check-that-resources-calen.patch
@@ -0,0 +1,123 @@
+From f73e082654a88617439043454b45bf950d168dfc Mon Sep 17 00:00:00 2001
+From: David Jarvie <djarvie@kde.org>
+Date: Thu, 29 Mar 2012 00:29:03 +0100
+Subject: [PATCH 6/6] Bug 296383: during startup, check that resources
+ calendar opens ok
+
+Prevent crash in program initialisation by checking that the
+resources calendar has opened successfully.
+
+BUG:296383
+
+Backport of 4a3204b75464406ab3b3505e2fe222937aac6750 (master)
+---
+ kalarm/Changelog | 3 ++-
+ kalarm/alarmcalendar.cpp | 19 ++++++++++++++++---
+ kalarm/alarmcalendar.h | 4 ++--
+ kalarm/kalarmapp.cpp | 3 ++-
+ 4 files changed, 22 insertions(+), 7 deletions(-)
+
+diff --git a/kalarm/Changelog b/kalarm/Changelog
+index 7caf1dd..e2aee86 100644
+--- a/kalarm/Changelog
++++ b/kalarm/Changelog
+@@ -1,10 +1,11 @@
+ KAlarm Change Log
+
+-=== Version 2.4.12 --- 26 April 2011 ===
++=== Version 2.4.12 --- 29 March 2012 ===
+ - Fix crash on some systems when New Alarm dialogue is displayed from system tray
+ icon menu.
+ - Fix KAlarm button in alarm window not always showing main window and not
+ highlighting the alarm in the main window.
++- Fail cleanly if calendar resources fail to open.
+
+ === Version 2.4.11 (KDEPIM 4.4.11) --- 16 April 2011 ===
+ - Fix bad borders round left hand buttons of time spinboxes in Oxygen style.
+diff --git a/kalarm/alarmcalendar.cpp b/kalarm/alarmcalendar.cpp
+index 0b6eed8..281b58c 100644
+--- a/kalarm/alarmcalendar.cpp
++++ b/kalarm/alarmcalendar.cpp
+@@ -1,7 +1,7 @@
+ /*
+ * alarmcalendar.cpp - KAlarm calendar file access
+ * Program: kalarm
+- * Copyright © 2001-2009 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2001-2012 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -187,11 +187,24 @@ AlarmCalendar::~AlarmCalendar()
+ }
+
+ /******************************************************************************
++* Check whether the calendar is open.
++*/
++bool AlarmCalendar::isOpen()
++{
++ if (mOpen && mCalType == RESOURCES && !AlarmResources::instance())
++ {
++ mCalendar = 0;
++ mOpen = false;
++ }
++ return mOpen;
++}
++
++/******************************************************************************
+ * Open the calendar if not already open, and load it into memory.
+ */
+ bool AlarmCalendar::open()
+ {
+- if (mOpen)
++ if (isOpen())
+ return true;
+ if (mCalType == RESOURCES)
+ {
+@@ -233,7 +246,7 @@ bool AlarmCalendar::open()
+ delete mCalendar;
+ mCalendar = 0;
+ }
+- return mOpen;
++ return isOpen();
+ }
+
+ /******************************************************************************
+diff --git a/kalarm/alarmcalendar.h b/kalarm/alarmcalendar.h
+index be4537d..1535dd0 100644
+--- a/kalarm/alarmcalendar.h
++++ b/kalarm/alarmcalendar.h
+@@ -1,7 +1,7 @@
+ /*
+ * alarmcalendar.h - KAlarm calendar file access
+ * Program: kalarm
+- * Copyright © 2001-2009 by David Jarvie <djarvie@kde.org>
++ * Copyright © 2001-2012 by David Jarvie <djarvie@kde.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+@@ -78,7 +78,7 @@ class AlarmCalendar : public QObject
+ KAEvent* updateEvent(const KAEvent*);
+ bool deleteEvent(const QString& eventID, bool save = false);
+ void purgeEvents(const KAEvent::List&);
+- bool isOpen() const { return mOpen; }
++ bool isOpen();
+ QString path() const { return (mCalType == RESOURCES) ? QString() : mUrl.prettyUrl(); }
+ QString urlString() const { return (mCalType == RESOURCES) ? QString() : mUrl.url(); }
+ void adjustStartOfDay();
+diff --git a/kalarm/kalarmapp.cpp b/kalarm/kalarmapp.cpp
+index e472bac..f432860 100644
+--- a/kalarm/kalarmapp.cpp
++++ b/kalarm/kalarmapp.cpp
+@@ -1953,7 +1953,8 @@ bool KAlarmApp::initCheck(bool calendarOnly)
+ */
+ AlarmCalendar::displayCalendar()->open();
+
+- AlarmCalendar::resources()->open();
++ if (!AlarmCalendar::resources()->open())
++ return false;
+ setArchivePurgeDays();
+
+ firstTime = false;
+--
+1.7.9.2
+
diff --git a/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild b/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild
new file mode 100644
index 000000000000..34870066afff
--- /dev/null
+++ b/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/kalarm-4.4.11.1-r2.ebuild,v 1.1 2012/08/01 22:49:10 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+inherit kde4-meta
+
+DESCRIPTION="Personal alarm message, command and email scheduler for KDE"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim)
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/libxslt
+"
+
+KMEXTRACTONLY="
+ kmail/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.11.1-underlinking.patch"
+ "${FILESDIR}/4.4/"000{1,3,6}-*.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_akonadi=OFF
+ -DXSLTPROC_EXECUTABLE="${EPREFIX}"/usr/bin/xsltproc
+ )
+ kde4-meta_src_configure
+}