summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-02 20:24:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-02 20:24:50 +0000
commit5b57d156ffab1f35f6da66084aa37a39cfd10c08 (patch)
tree3b13e1de559bcf990b1b1194f4eeafede86e15d9 /gnome-base/orbit
parentMinor typo in USE doc installation. (diff)
downloadgentoo-2-5b57d156ffab1f35f6da66084aa37a39cfd10c08.tar.gz
gentoo-2-5b57d156ffab1f35f6da66084aa37a39cfd10c08.tar.bz2
gentoo-2-5b57d156ffab1f35f6da66084aa37a39cfd10c08.zip
Fix test killing wrong process, bug #268142.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog5
-rw-r--r--gnome-base/orbit/orbit-2.14.17.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 0f4bd1fa3ab9..cf8e27e93731 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.148 2009/03/17 15:17:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.149 2009/08/02 20:24:50 eva Exp $
+
+ 02 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org> orbit-2.14.17.ebuild:
+ Fix test killing wrong process, bug #268142.
17 Mar 2009; Mart Raudsepp <leio@gentoo.org> orbit-2.14.17.ebuild:
Fix cross-compilation, bug 262741. Thanks to Maksim Melnikau.
diff --git a/gnome-base/orbit/orbit-2.14.17.ebuild b/gnome-base/orbit/orbit-2.14.17.ebuild
index ac0c2387fbab..e5e1eb905aaa 100644
--- a/gnome-base/orbit/orbit-2.14.17.ebuild
+++ b/gnome-base/orbit/orbit-2.14.17.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.3 2009/03/17 15:48:59 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.4 2009/08/02 20:24:50 eva Exp $
+EAPI="2"
GCONF_DEBUG="no"
inherit gnome2 toolchain-funcs
@@ -28,6 +29,14 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed failed"
+}
+
src_compile() {
# We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
# files to be not found by autotools when compiling ORBit. See bug #58540