summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.17.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.17.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnome-base/orbit/orbit-2.14.17.ebuild b/gnome-base/orbit/orbit-2.14.17.ebuild
index ac0c2387fbab..e5e1eb905aaa 100644
--- a/gnome-base/orbit/orbit-2.14.17.ebuild
+++ b/gnome-base/orbit/orbit-2.14.17.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.3 2009/03/17 15:48:59 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.4 2009/08/02 20:24:50 eva Exp $
+EAPI="2"
GCONF_DEBUG="no"
inherit gnome2 toolchain-funcs
@@ -28,6 +29,14 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed failed"
+}
+
src_compile() {
# We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
# files to be not found by autotools when compiling ORBit. See bug #58540