summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-08-18 19:14:57 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-08-18 19:14:57 +0000
commit4472cad8ba8701caa372b32e9abdb68a56e2aa92 (patch)
tree2229f3c988d44b480f47e164662851d659a62bfb /gnome-base/orbit
parentFixed EOLs in make.defaults. (diff)
downloadgentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.tar.gz
gentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.tar.bz2
gentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.zip
fix orbit-2* ebuilds to unset IDL_DIR before compiling (bug #58540)
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog6
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.12.22
-rw-r--r--gnome-base/orbit/orbit-2.12.2.ebuild13
-rw-r--r--gnome-base/orbit/orbit-2.12.5.ebuild11
-rw-r--r--gnome-base/orbit/orbit-2.14.0.ebuild11
-rw-r--r--gnome-base/orbit/orbit-2.14.2.ebuild11
6 files changed, 48 insertions, 6 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 47b839843bee..2975d7f3f10a 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.74 2006/08/16 13:58:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.75 2006/08/18 19:14:57 compnerd Exp $
+
+ 18 Aug 2006; Saleem Abdulrasool <compnerd@gentoo.org> orbit-2.12.2.ebuild,
+ orbit-2.12.5.ebuild, orbit-2.14.0.ebuild, orbit-2.14.2.ebuild:
+ Adding in unset IDL_DIR to fix compile for people using RSI's IDL
16 Aug 2006; Markus Rothe <corsair@gentoo.org> orbit-2.14.0.ebuild:
Stable on ppc64
diff --git a/gnome-base/orbit/files/digest-orbit-2.12.2 b/gnome-base/orbit/files/digest-orbit-2.12.2
index f654bb6e22aa..7c946a3dcdde 100644
--- a/gnome-base/orbit/files/digest-orbit-2.12.2
+++ b/gnome-base/orbit/files/digest-orbit-2.12.2
@@ -1 +1,3 @@
MD5 7f963dcd0d84e6854460449383cc8c70 ORBit2-2.12.2.tar.bz2 678266
+RMD160 f3ade6fe1d99c7becadf65630721378fff603c37 ORBit2-2.12.2.tar.bz2 678266
+SHA256 11f21cceb9897139e7772daf1bfcd993cf363e0c5d4caa43f5abb111d5e11813 ORBit2-2.12.2.tar.bz2 678266
diff --git a/gnome-base/orbit/orbit-2.12.2.ebuild b/gnome-base/orbit/orbit-2.12.2.ebuild
index cbfe1a3195c9..06fc39d75f30 100644
--- a/gnome-base/orbit/orbit-2.12.2.ebuild
+++ b/gnome-base/orbit/orbit-2.12.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.2.ebuild,v 1.10 2005/07/30 12:30:26 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.2.ebuild,v 1.11 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2 eutils
@@ -35,3 +35,12 @@ MAKEOPTS="${MAKEOPTS} -j1"
USE_DESTDIR="1"
DOCS="AUTHORS ChangeLog README HACKING NEWS TODO MAINTAINERS"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}
diff --git a/gnome-base/orbit/orbit-2.12.5.ebuild b/gnome-base/orbit/orbit-2.12.5.ebuild
index 6a87763a665e..9fb198d82375 100644
--- a/gnome-base/orbit/orbit-2.12.5.ebuild
+++ b/gnome-base/orbit/orbit-2.12.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.5.ebuild,v 1.10 2006/07/05 05:38:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.5.ebuild,v 1.11 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2
@@ -40,3 +40,12 @@ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
pkg_setup() {
G2CONF="$(use_enable static)"
}
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}
diff --git a/gnome-base/orbit/orbit-2.14.0.ebuild b/gnome-base/orbit/orbit-2.14.0.ebuild
index c1d03fe61077..4a001f0d4e84 100644
--- a/gnome-base/orbit/orbit-2.14.0.ebuild
+++ b/gnome-base/orbit/orbit-2.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.8 2006/08/16 13:58:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.9 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2
@@ -39,3 +39,12 @@ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
pkg_setup() {
G2CONF="${G2CONF} $(use_enable static)"
}
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}
diff --git a/gnome-base/orbit/orbit-2.14.2.ebuild b/gnome-base/orbit/orbit-2.14.2.ebuild
index d953369ca719..a05477dac164 100644
--- a/gnome-base/orbit/orbit-2.14.2.ebuild
+++ b/gnome-base/orbit/orbit-2.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.2.ebuild,v 1.2 2006/07/26 04:38:28 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.2.ebuild,v 1.3 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2
@@ -33,3 +33,12 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}