summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.0.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnome-base/orbit/orbit-2.14.0.ebuild b/gnome-base/orbit/orbit-2.14.0.ebuild
index c1d03fe61077..4a001f0d4e84 100644
--- a/gnome-base/orbit/orbit-2.14.0.ebuild
+++ b/gnome-base/orbit/orbit-2.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.8 2006/08/16 13:58:04 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.0.ebuild,v 1.9 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2
@@ -39,3 +39,12 @@ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
pkg_setup() {
G2CONF="${G2CONF} $(use_enable static)"
}
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}