summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-15 08:55:06 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-15 08:55:06 +0000
commitc32a5723c1c3579cf2b14645e72468ab9f264be3 (patch)
tree638f455ad461c55390636af5a222e660c5698762 /games-sports
parentSLOT 0.6.x but leave 0.7.x alone #52509 / #44258 (Manifest recommit) (diff)
downloadgentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.tar.gz
gentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.tar.bz2
gentoo-2-c32a5723c1c3579cf2b14645e72468ab9f264be3.zip
work with the new 0.6.5 install style
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/trophy/trophy-1.1.3.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-sports/trophy/trophy-1.1.3.ebuild b/games-sports/trophy/trophy-1.1.3.ebuild
index 7797e4d3ba5f..7c584631cd84 100644
--- a/games-sports/trophy/trophy-1.1.3.ebuild
+++ b/games-sports/trophy/trophy-1.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.3.ebuild,v 1.5 2004/06/24 23:25:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.3.ebuild,v 1.6 2004/08/15 08:54:21 vapier Exp $
-inherit games
+inherit games flag-o-matic
MY_P="${P}-src"
S="${WORKDIR}/${MY_P}"
@@ -12,26 +12,28 @@ SRC_URI="mirror://sourceforge/trophy/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
IUSE=""
DEPEND="=dev-games/clanlib-0.6.5*
>=media-libs/hermes-1.3.2
>=sys-libs/zlib-1.1.3"
-pkg_setup() {
- clanlib-config 0.6.5
-}
-
src_unpack() {
unpack ${A}
cd ${S}
find -name ".cvsignore" -exec rm -f \{\} \;
+ sed -i \
+ -e '/^EXTERN_LIBS/s:= := ${LDFLAGS} :' \
+ -e 's:-O3::' \
+ trophy/Makefile.in
}
src_compile() {
cd trophy
autoconf || die "autoconf failed"
+ append-flags -I${ROOT}/usr/include/clanlib-0.6.5
+ append-ldflags -L${ROOT}/usr/lib/clanlib-0.6.5
egamesconf || die
emake || die "emake failed"
}